Support » Plugin: WordPress Tables » Links in tables do not fire fancybox

  • Resolved @anansi.pro

    (@mahasvin)


    My case is a little weird. Links in table, although rendered correctly from csv have ‘fancybox’ class that has to load images associated with objects in table in a lightbox. Although fancybox loads correctly everywhere but in this table. What should I fix in your plugin to make fancybox event correctly initialised for such links?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Ian Sadovy

    (@iansadovy)

    Hello @yerio,

    Thank you for the question.
    I need some time to look closer into your case, but I think that forcing fancybox to re-process all links after the table is rendered should help.
    I will check it and let you know.

    Plugin Author Ian Sadovy

    (@iansadovy)

    @yerio,

    Could you please specify what version of fancyBox you are using?
    I have tried with fancyBox v3.1.20 and it seems working as expected.
    My link looks like the following:
    <a href="image.jpg" data-fancybox>My Link</a>

    Looking forward to hearing from you.

    Regards,
    Ian

    Its 1.3.6 and we have number of websites with it. <a class='fancybox' href='image.jpg'> Link </a> style links do not fire.

    Plugin Author Ian Sadovy

    (@iansadovy)

    Thanks @yerio, I will check this specific version and link style and will let you know.

    Thank you for telling fancybox3 is OK. I dropped in fancybox3 and it started to work.

    • This reply was modified 3 years, 4 months ago by @anansi.pro.
    Plugin Author Ian Sadovy

    (@iansadovy)

    Glad to hear that fancybox3 is working for you.
    So, I am closing this ticket for now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Links in tables do not fire fancybox’ is closed to new replies.