Support » Fixing WordPress » Links, html, images etc & external application problem

  • Hi all, I have a just started to use WP for a personal site and have two issues, I will list them below…

    1. I can’t seem to post any kind of ‘dynamic’ content within my WP posts. when I post any type of link, image or similar I find that it does not post and one I try to ‘publish’ the post it forwards me to the parent website and the post is not published, so basically one I have pressed the publish button it will forward me to http://www.[mydomain].com/ rather than back to the ‘write’ panel within the WP admin pages.

    2. this issue is me trying to post with an external application like, mars edit, or MacJurnal or any other application (I have tried pretty much all of them), all do exactly the same thing, I can enter my login details and when I think it tries to communicate with the WP server (on my host) and doesn’t ‘connect’ I have a feeling it is a problem with the ‘xmlrpc.php’ file, but I might be wrong.

    If anyone can help me out with these issue I would really appreciate it. My blog is pretty private but if a Mod would like the details I can PM this to get to the bottom of it.

    I am using 2.6.2 (this even happened with 2.5.x or 2.6.x) on a Mac, have tried Firefox, Camino, IE (PC) Safari all do the same with the posting issue.

    Thanks guys in advance.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Can anyone help me with this?

    I am mainly concerned that I can’t post any links or pictures in anyway.




    …publish button it will forward me to http://www.[mydomain].com/ rather than back to the ‘write’ panel within the WP admin pages.

    Ok, so you can post things without links, images, etc?? That works?

    And what happens on a pc?

    Hey, thanks for the reply 🙂

    Yes all publishing work no problem, but it’s just anything else, like links, media, pictures etc but yes posting text is fine.

    I have done this on a PC too and still the same thing.

    But the weird thing is… when I press ‘publish’ (or save) it will then reload the page, but go to the ‘main’ URL meaning…

    My blog page: http://www.[mydomain].com/blog
    this is where it redirects to after ‘publish or save’: http://www.[mydomain].com

    I’m having the same problem – posting any sort of HTML (links, images, strong, em etc.) results in being forwarded to the front page of the site when submitting the edit form. This is with a new install of WP 2.6.2. The same happens whether the visual editor is on or not.




    just out of curiosity, and to rule a coincidence out — can you 2 tell me/us who your web hosts are?

    Hi whooami,

    My host is eUKHost hosted in the UK (I live in Amsterdam) just a side note, I a have tried different themes and even the default theme causes the same issue.

    PS. I would like to keep my blog secret purely because t is private, but I could setup another one on another domain as a test, will do this later today and post up details.

    The same happens to me

    Strangely I also host with eUKHost so maybe that could be the problem. That said I have half a dozen blogs hosted with them, and only have a problem with this one..




    hmm, the plot thickens.

    Ill go one further in the questions 🙂

    do this, for me dejunky

    nslookup (put your domain there) and tell us what IP comes back. Is it this one?

    oooh so it might be the Host.


    Also just installed 2.6.2 on (quick test) and it is doing the same thing, this time it was a manual install and on my other domain it was done via Fantastico.

    The same think is happeining to me. (Didn’t do it in the past).
    And it is happening to lots of others too. for example

    I posted a message about this on Friday and Otto42 (who seems to be a bit of whiz) said that the problem ws with security at the hosts.

    I also host with eukhost.

    Would love to get this sorted.
    Anybody know the answer to this annoying problem.

    hmmm, there really seems to be a problem, anyone with eUKhost got an answer to this from them?

    I wonder what the ‘security’ issue is? anyone?

    Just got in touch with eukhost via Live Chat and they sorted the problem.

    Here follows the chat transcript.

    I suggest you do the same.



    Please wait for a site operator to respond.
    You are now chatting with ‘Shaun’
    Shaun: Hello and Welcome to Live Chat Support.
    Shaun: How may I assist you today ?
    Brian: Having problems with WordPress.
    Brian: WordPress says that I need to talk to your host. It’s likely that the server is configured with too strict security settings.
    Brian: Has the security settings been changed for my account?
    Shaun: Let me know your domain name, please.
    Shaun: Give me a moment please. I am looking into this.
    Shaun: take look now
    Brian: I’ll look now.
    Shaun: ok
    Brian: Great all working now
    Brian: what was the problem?
    Shaun: I have disable mod security for your domain
    Brian: OK thanks
    Brian: Bye
    Shaun: You are most welcome.
    Shaun: Bye for now

    I guess I should have thought of it earlier 🙂 but thanks Brian, talking to them now, I hope it also works for me.

    [UPDATE] yep works! must be something the eUKhost is doing at their end.

    Cheers dude.

    Thanks Brian

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Links, html, images etc & external application problem’ is closed to new replies.