Support » Fixing WordPress » Links from main blog page not working : 404 output appears.

  • Hi, I need urgent help. My blog site is http://blog.mysuccessmantra.com
    Recently I realized that the links on the front page are not leading to the actual pages but to 404 error pages. I had to reformat the 404 page to redirect customers to alternate blog sites.

    I checked the dashboard and the edit buttons work, that is the right post data shows up, but if i preview the 404 page shows up.
    Any help appreciated.
    Regards,
    Anthony

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    (@esmi)


    Forum Moderator


    Try resetting your custom permalinks back to the default setting. If that works, then try reading Using_Permalinks before setting a custom permalink structure back up again.

    Thanks esmi setting the permalinks back to numeric solved it
    i had /%postname%/ in the custom permalinks box before.
    Can you tell me what went wrong with it?
    I believe using the postname as the link helps in SEO.

    esmi

    (@esmi)


    Forum Moderator


    I believe using the postname as the link helps in SEO.

    By all means include /%postname%/ in your custom permalink structure but always try to have a numeric at the start of the custom structure. The reasons for this are explained in Using_Permalinks. Your SEO will not suffer as a result, in my experience.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Links from main blog page not working : 404 output appears.’ is closed to new replies.