Support » Fixing WordPress » Links don’t click

  • olinerp

    (@olinerp)


    Hi,
    I set two links (an email and a form to download) but they are not even clickable. I searched on this and other forums, but I don’t understand what the problem may be. I remember that until a couple of months ago everything was working properly.
    I hope you can help me! Thanks!

    • This topic was modified 1 month ago by  olinerp.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • lisa

    (@contentiskey)

    what was the most recent change made?
    did you recently change to HTTPS?

    olinerp

    (@olinerp)

    Hi Lisa,
    After tried “broken links checker” and installing a WP default theme, I deleted all my custom CSS and I’ve found the issue.
    At the end of custom CSS I inserted some custom background images, and it seems that these give an effect of “overlap” or “overflow” to the layer of clickable links.
    Is there a way to solve this problem keeping both backgrounds and links?
    Thanks a lot,
    Quirino

    ronaldvw

    (@ronaldvw)

    Hi,

    the issue is caused by the background-image on the content wrap, overlapping that sections content, combined with CSS rules for the has-section-background-image selector (the absolute positioning), see screenshot:

    http://vanweerd.com/screenshots/s20190916150105.jpg

    Removing the rule for the has-section-background-image class, or just removing the absolute positioning will resolve this, however, this may have other side-effects. You could try the find another way to add a background-color, rather than using a fixed size background-image. You might want to ask the theme developer for more details on why this was designed this way.

    EDIT:
    After submitting I saw your reply. Using the background-color property should work just as well (since it is a solid color): https://devdocs.io/css/background-color

    • This reply was modified 1 month ago by  ronaldvw.
    olinerp

    (@olinerp)

    Hi ronaldvw,
    thank you for your comprehensive explanation (since I am a beginner I understood about half of it, but it will be useful for me me to go into the problems related to “positions”).
    In the end I think I will have to replace the images with colors, but I will ask the theme developer about this issue.
    Kind regards, and thanks again
    Quirino

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.