Support » How-To and Troubleshooting » Links do not work

Links do not work

  • Hi everyone

    I just finished installing WordPress for the first time – so I am new at this.

    I’ve installed WordPress in a directory called ‘Boomer-Blog’ (I own the boomer-blog.com domain) under the htdocs directory which is the main document directory for my Apache web server. My main personal web site is http://www.desautel.net, and going to it opens the index.htm file in the htdocs directory.

    I do not have a static IP address, so I use a dynamic DNS service. The service also provides a thing called webhop, which allows you to redirect requests for other domains that you might own to a subdirectory on your main site.

    For instance, my political site is newdoi.com (for new Declaration of Independence). Typing http://www.newdoi.com in a browser actually sends you to http://www.desautel.net/newdoi/.

    I did the same thing with boomer-blog.com, which actually sends you to http://www.desautel.net/Boomer-Blog/. This works OK, and will take me to the main wordpress blog page on my Linux machine.

    The problem I’m having is that the meta links at the bottom-right of the main page do not work correctly. Choosing the ‘login’ link does take me to the login page, but after entering my information and clicking on ‘login’, the page just refreshes itself and erases the data I entered.

    However, at this point the page HAS logged me in. If I hit the browser refresh button, it takes me back to the main blog page, and the ‘login’ meta link has now changed to ‘logout’.

    However, the ‘site admin’ link is worse. Using that link just refreshes the main blog page. If I open the link in a new window, I get a blank window, even the address bar is blank. Refreshing here does nothing.

    If I enter http://www.boomer-blog.com/wp-admin/ in the browser address bar, I get the same blank page, except the address remains in the address bar. Refreshing does nothing.

    If I enter http://www.boomer-blog.com/wp-admin/index.php, I get the same blank page.

    Anyone have any ideas??


Viewing 5 replies - 1 through 5 (of 5 total)
  • WP “hates” this kind of redirects – I didn’t see any working solutions for that. I am afraid you will have to
    a) either have a real domain for the boomer-blog or
    b) make just a simple subfolder on your existing domain

    Does this mean that I should make the main address for boomer-blog the following:



    That sort of defeats the purpose of owning the domain name boomer-blog.com, doesn’t it?

    In the case of WP the trick described by you in the OP doesn’t work*. Believe me, if there was a solution I’d tell you… I went through this several times with other users. Never worked. Sorry.

    *explanation: the two URIs for blog and WP, set in the Options > General, are stored in the database and every link is built on those data.

    Oh, I believe you. I’m just wondering if there is a way to let two domain names (desautel.net & boomer-blog.com) share the same dynamic IP address, and yet have the router, Linux machine, or Apache server differentiate between them as requests come in, routing the requests to the appropriate directories?

    Maybe using different ports? Or, if I make boomer-blog.com a virtual host in Apache, would that help?

    Or are we saying that there is no way to make WordPress work as its own domain unless there is an entire web server dedicated to it?

    Hi Moshu

    I’m wondering what the other members who you said were trying the same webhop type of redirection ended up doing?

    If a member wants to run WordPress on their own web server, which has a direct address like desautel.net, and we cannot use a redirection to allow the address of the blog to be something like boomer-blog.com, then does the blog address have to be something like http://www.desautel.net/Boomer-Blog/?


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Links do not work’ is closed to new replies.
Skip to toolbar