Support » Fixing WordPress » Links Disappearing

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi

    (@esmi)

    Forum Moderator

    Are you switching between editing tabs?

    No. Just read on another thread that it has to do with the Center Align Button. She suggested typing it all in Word then moving it all over to Edit when ready to post. Very frustrating.

    esmi

    (@esmi)

    Forum Moderator

    She suggested typing it all in Word then moving it all over to Edit when ready to post.

    Noooo! Don’t paste content from Microsoft Word into WordPress as the pasted text will also contain Word’s own formatting. Sooner or later, this formatting will stop your pages from being displayed correctly (if at all) in Internet Explorer. If you cannot possibly manage without Word, paste your text into NotePad (or another text editor) first, then copy from NotePad into WordPress. Or use Windows LiveWriter or a similar desktop blogging tool.

    And you didn’t answer my original question – are you switching between editing tabs?

    No, not switching back and forth b/w editors. I am on a Mac. Will NotePad work for me? I have never used a text editor. Thx

    esmi

    (@esmi)

    Forum Moderator

    You shouldn’t have to use NotePad. Or anything else for that matter. Can you describe the process you use when adding your links – starting with which editor you are using.

    Using Visual Editor. I typically type in the text. Highlight and copy the url for the site I will be linking to. Use the link button to add the link to the text.

    Usually preview my post a few times during editing. When I go back to Edit mode, some are missing.

    Thx

    esmi

    (@esmi)

    Forum Moderator

    Are these links being formatted as headings or a bulleted list?

    Simply text centered above a photo to credit the owner.

    I am having a similar problem. I’m trying to link to other posts within my site, under a photo (centered) and when I save, half the links disappear and extra spaces are added in between each item/photo.

    I tried just fixing the spacing issue and when I hit save, everything returned to how it was and more links were dropped. It’s incredibly frustrating. Have you been able to figure anything out?

    @keepinitkind Not yet:(. I am dealing with the spacing issue as well. Please let me know if you find a solution!

    esmi

    (@esmi)

    Forum Moderator

    @keepinitkind: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem – despite any similarity in symptoms – is likely to be completely different.

    esmi

    (@esmi)

    Forum Moderator

    @amandajanebrown: what happens if you add a few line breaks between the link and the image? (I realise that’s not what you really want but please bear with me whilst we try to get to the bottom of this).

    Still losing the link, even with a line break.

    esmi

    (@esmi)

    Forum Moderator

    I’ve tried to replicate your problem on one of my sites.
    I’ve tried adding the link before the inserting the image.
    I’ve tried inserting the image first and then adding the link above it.
    I’ve tried using both the Visual and Text editor.
    I’ve tried previewing both published and draft Posts

    But the link absolutely refuses to vanish for me. Can you try replicating the problem using the default theme with all plugins deactivated?

    I just installed the WP 3.5.1 update and it seems to be working now. I sincerely appreciate your help. Being new to WP is like learning a foreign language.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Links Disappearing’ is closed to new replies.