WordPress HTTPS (SSL)
Links changing from https to http ...not the desired behavior (3 posts)

  1. smeyer012
    Posted 2 years ago #

    I am having difficulty with links dynamically generated in wp_head, for instance, like enqueued scripts and plugin resources or any dynamically generated url within my theme code. They are using http instead of https, even though the url in the database is https. I've tried implementing this plugin to address the problem and it is now forcing even hard coded links to http instead of https, which is breaking the link to the css file, etc. This seems counter-intuitive. Am I missing something?


  2. dabernathy89
    Posted 2 years ago #

    I'm having the same issue, but only with one link. Stored correctly in the database, but displayed with http. Very strange.


    edit: okay the only reason I hadn't noticed this until now is that the script I'm trying to load can ONLY be loaded via https. this plugin's behavior is a little frustrating.

  3. davidddn
    Posted 2 years ago #

    Is this an acknowledged issue?

    At the least there should be an option to ignore urls or matched strings. I had a big problem with some tracking code for a 3rd party site not responding because the plugin was force rewriting the https to http (on a http page).

    I've temporarily disabled the public function makeUrlHttp( $string completely

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.