Support » Plugin: Gallery Custom Links » Links are not working? Please check this

  • ResolvedPlugin Author Jordy Meow

    (@tigroumeow)


    The issue is that this is not one problem. There are probably as many different problems as we have users. Of course, the resulting effect is that “it is not working”, and for this plugin, it means the linking doesn’t work.

    The plugin works (it does, many users are happy with it), but it doesn’t work with every single plugins, themes and caching solutions available. That’s impossible.

    Please don’t participate in the threads mentioning that general issue, nobody will be able to help.

    Please open a new thread, with the name of the page builder you are using, the gallery plugin, and in the text, mention also the theme you are using. For example “Link doesn’t work [X-Theme / NextGEN]”. That will make the debugging possible. Thank you 🙂

    Also, if you really want some help, please install Local (a tool that allows you to create local websites), and re-create the issue. Use the least plugins as possible, and only one image or two. With Local, you can export that website to a file; please share this file somewhere online and a link to it.

Viewing 15 replies - 16 through 30 (of 33 total)
  • Same issue as others.

    [21-Nov-2020 13:53:09] WARNING: [pool convesio] child 2111 said into stderr: ” thrown in /var/www/html/wordpress/wp-content/plugins/gallery-custom-links/classes/core.php on line 168″
    2020-11-21T13:53:11.377991066Z [21-Nov-2020 13:53:11] WARNING: [pool convesio] child 2113 said into stderr: “NOTICE: PHP message: PHP Warning: Cannot modify header information – headers already sent in /var/www/html/wordpress/wp-content/plugins/nitropack/functions.php on line 2122”
    2020-11-21T13:53:12.378072346Z [21-Nov-2020 13:53:11] WARNING: [pool convesio] child 2113 said into stderr: “NOTICE: PHP message: PHP Warning: Cannot modify header information – headers already sent in /var/www/html/wordpress/wp-content/plugins/nitropack/functions.php on line 2122”
    2020-11-21T13:53:41.381002395Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “NOTICE: PHP message: PHP Fatal error: Uncaught Error: Class ‘KubAT\PhpSimple\HtmlDomParser’ not found in /var/www/html/wordpress/wp-content/plugins/gallery-custom-links/classes/core.php:168”
    2020-11-21T13:53:41.381042601Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “Stack trace:”
    2020-11-21T13:53:41.381048031Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#0 [internal function]: Meow_MGCL_Core->linkify(‘…’, 9)”
    2020-11-21T13:53:41.381052947Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#1 /var/www/html/wordpress/wp-includes/functions.php(4669): ob_end_flush()”
    2020-11-21T13:53:41.381057213Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#2 /var/www/html/wordpress/wp-includes/class-wp-hook.php(287): wp_ob_end_flush_all(”)”
    2020-11-21T13:53:41.381061538Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#3 /var/www/html/wordpress/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)”
    2020-11-21T13:53:41.381066134Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#4 /var/www/html/wordpress/wp-includes/plugin.php(478): WP_Hook->do_action(Array)”
    2020-11-21T13:53:41.381070377Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#5 /var/www/html/wordpress/wp-includes/load.php(1001): do_action(‘shutdown’)”
    2020-11-21T13:53:41.381074623Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#6 [internal function]: shutdown_action_hook()”
    2020-11-21T13:53:41.381078638Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: “#7 {main}”
    2020-11-21T13:53:41.381082904Z [21-Nov-2020 13:53:40] WARNING: [pool convesio] child 2158 said into stderr: ” thrown in /var/www/html/wordpress/wp-content/plugins/gallery-custom-links/classes/core.php on line 168″

    Pineapple House Rules

    (@batalidioranddeweywalkintoabar)

    Here is my PHP Error:

    [21-Nov-2020 15:40:36 UTC] PHP Fatal error: Uncaught Error: Class ‘KubAT\PhpSimple\HtmlDomParser’ not found in /srv/htdocs/wp-content/plugins/gallery-custom-links/classes/core.php:168

    Everything was working beautifully, but now no links are working.

    https://pineapplehouserules.com/recipe-index/

    ablohm

    (@ablohm)

    Same problem here… ‘KubAT\PhpSimple\HtmlDomParser’ not found

    🙁

    ferrtx

    (@ferrtx)

    He estado revisando el archivo error.log pero no muestra nada referente a este plugin y el último error registro es del día 12 nov
    Y no funciona el plugin pero tendremos paciencia para que el desarrollador lo solucione, mientras wordpress nos obliga a depender de un plugin para añadir simples enlaces a las galerias.. no debe ser necesario depender de este plugin para algo tan sencillo que wodpress no soluciona.
    [12-Nov-2020 14:54:23 UTC] Linker: Found img tag with classes: custom-logo
    [12-Nov-2020 15:01:05 UTC] Linker: Found img tag with classes: custom-logo

    natiten

    (@natiten)

    Buenas tardes. Tengo el mismo problema, el complemento estuvo funcionando a la perfección hasta ayer (es realmente buenísimo y muy sencillo e intuitivo de usar), pero parece que con la última actualización algo ocurrió.
    Me podrían por favor ayudar para saber cómo regresar a una versión anterior? El tema que estoy utilizando el Theme Blossom Travel y la versión de WP 5.5.3

    Desde ya, muchísimas gracias!!!

    smwright

    (@smwright)

    None of my links are going to the URL either but instead are going to the media file.

    I am using the most recent version of the plugin as well (2.0.1). I am on WordPress 5.5.2, and your server is running PHP 7.2 and MySQL 5.6

    I had to disable the plugin as I was getting error 500 and it was causing my site to go down.

    Issue Log:

    [21-Nov-2020 19:13:39 UTC] PHP Fatal error: Uncaught Error: Class ‘KubAT\PhpSimple\HtmlDomParser’ not found in /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-content/plugins/gallery-custom-links/classes/core.php:168
    Stack trace:
    #0 [internal function]: Meow_MGCL_Core->linkify(‘<!DOCTYPE html>…’, 9)
    #1 /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-includes/functions.php(4673): ob_end_flush()
    #2 /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-includes/class-wp-hook.php(287): wp_ob_end_flush_all(”)
    #3 /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(”, Array)
    #4 /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #5 /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-includes/load.php(1007): do_action(‘shutdown’)
    #6 [internal function]: shutdown_action_hook()
    #7 {main}
    thrown in /home/216997.cloudwaysapps.com/srsxnuyhxw/public_html/wp-content/plugins/gallery-custom-links/classes/core.php on line 168

    Plugin Author Jordy Meow

    (@tigroumeow)

    The version 2.0.2 should fix this 🙂

    ferrtx

    (@ferrtx)

    Todo solucionado
    He actualizado a la versión 2.0.2 y el plugin funciona correctamente en WP 5.5.3 con OceanWP

    Muchas gracias y buen trabajo!!

    marywt

    (@marywt)

    Thanks Jordy!
    2.0.2 does it for me and my site is back to how I want it.

    Amazing support for a free plugin. This should do wonders for your reputation, which was already good!

    Plugin Author Jordy Meow

    (@tigroumeow)

    Thank you so much, that’s really kind! Made my day 🙂

    smwright

    (@smwright)

    My site is also back up and running perfectly, thank you so much Jordy for fixing that, it’s SOOOOOOOO appreciated, you don’t even know! Thank you, thank you, thank you!!!! -Stephanie

    Plugin Author Jordy Meow

    (@tigroumeow)

    Thank you 🙂 Don’t hesitate to leave a little review, that always helps… even if what happened here is that I introduced an issue, then fixed it 😉

    natiten

    (@natiten)

    ¡Muchísimas Gracias Jordy!

    El complemento está funcionando a la perfección, no te imaginas cómo nos ayuda!!!! Gracias, gracias, gracias, por toda la labor que realizan personas como tú, se nota que aman su profesión!
    Abrazo!!!

    kpurvis

    (@kpurvis)

    I’ve read all your comments on this, I am trying to update the 2.02 and I am getting an error in my WP dashboard. I have no idea how to trouble shoot this. Error says:

    An error occurred while updating Gallery Custom Links: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions. vendor, vendor/kub-at, vendor/kub-at/php-simple-html-dom-parser, vendor/kub-at/php-simple-html-dom-parser/CONTRIBUTING.md, vendor/kub-at/php-simple-html-dom-parser/src, vendor/kub-at/php-simple-html-dom-parser/src/KubAT, vendor/kub-at/php-simple-html-dom-parser/src/KubAT/PhpSimple, vendor/kub-at/php-simple-html-dom-parser/src/KubAT/PhpSimple/lib, vendor/kub-at/php-simple-html-dom-parser/src/KubAT/PhpSimple/lib/simple_html_dom.php, vendor/kub-at/php-simple-html-dom-parser/src/KubAT/PhpSimple/HtmlDomParser.php, vendor/kub-at/php-simple-html-dom-parser/README.md, vendor/kub-at/php-simple-html-dom-parser/LICENSE, vendor/kub-at/php-simple-html-dom-parser/composer.json, vendor/bin, vendor/autoload.php, vendor/imangazaliev, vendor/imangazaliev/didom, vendor/imangazaliev/didom/src, vendor/imangazaliev/didom/src/DiDom, vendor/imangazaliev/didom/src/DiDom/Exceptions, vendor/imangazaliev/didom/src/DiDom/Exceptions/InvalidSelectorException.php, vendor/imangazaliev/didom/src/DiDom/ClassAttribute.php, vendor/imangazaliev/didom/src/DiDom/Node.php, vendor/imangazaliev/didom/src/DiDom/StyleAttribute.php, vendor/imangazaliev/didom/src/DiDom/Query.php, vendor/imangazaliev/didom/src/DiDom/Errors.php, vendor/imangazaliev/didom/src/DiDom/Encoder.php, vendor/imangazaliev/didom/src/DiDom/DocumentFragment.php, vendor/imangazaliev/didom/src/DiDom/Document.php, vendor/imangazaliev/didom/src/DiDom/Element.php, vendor/imangazaliev/didom/README-RU.md, vendor/imangazaliev/didom/CHANGELOG.md, vendor/imangazaliev/didom/README.md, vendor/imangazaliev/didom/.travis.yml, vendor/imangazaliev/didom/LICENSE, vendor/imangazaliev/didom/composer.lock, vendor/imangazaliev/didom/phpunit.xml, vendor/imangazaliev/didom/.gitignore, vendor/imangazaliev/didom/.php_cs, vendor/imangazaliev/didom/composer.json, vendor/composer, vendor/composer/autoload_real.php, vendor/composer/LICENSE, vendor/composer/installed.json, vendor/composer/autoload_classmap.php, vendor/composer/autoload_namespaces.php, vendor/composer/autoload_static.php, vendor/composer/autoload_psr4.php, vendor/composer/ClassLoader.php, gallery-custom-links.php, readme.txt, composer.lock, common, common/admin.css, common/img, common/img/meowapps.png, common/img/media-file-renamer.jpg, common/img/default.png, common/img/stackpath.png, common/img/wp-retina-2x.jpg, common/img/kinsta.png, common/img/meow-lightbox.jpg, common/img/meow-gallery.jpg, common/img/wplr-sync.jpg, common/img/media-cleaner.jpg, common/admin.php, button, button/native_gallery.php, button/gutenberg.php, button/meow_gallery.php, mgcl_extra.php, mgcl_admin.php, mgcl_linker.php, mgcl_core.php, composer.json

    ferrtx

    (@ferrtx)

    Hola
    Jordy te explicará mejor pero yo creo que algo tiene que ver la versión de php con la que esté trabajando su sitio web.
    En las herramientas de wordpress, puedes verificar el estado de salud del sitio y comprobar las posibles advertencias y la información de PHP, que debería ser php 7.0 o superior, esto se debe modificar y actualizar desde el servidor de alojamiento y quizás pueda solucionar el problema, siempre se puede hacer prueba actualizando por ejemplo a php 7.4 y si el sitio no responde, puede probar con PHP 7.3 Ó 7.2 hasta verificar cual es la versión mas alta que soorta tu sitio web.
    Yo creo que actualizando la versión de PHP solucionará el probglema o los permisos asignados.
    No creo que sea el plugin lo que ha provocado este error, si no que wordpress no lo soporta con versiones PHP muy bajas.

Viewing 15 replies - 16 through 30 (of 33 total)
  • You must be logged in to reply to this topic.