Support » Plugin: WordPress MU Domain Mapping » Links are not mapped :(

  • Hi. Today I was trying to fix a problem with sitemaps – they were created using the site-subdomain instead of the mapped domain.

    I’ve clicked around, deactivated the plugin, reactivated, republished some pages changed the mapped domain… and it did not help.

    BUT!!!

    ALL MY LINKS, INCLUDING THE MAIN MENU ARE NOW USING THE SITE_SUBDOMAIN URLS!!!

    I can still see my site under the mapped domain name and after clicking the name it reloads with the mapped domain BUT all the links point to the subdomain.

    Pleas, help me – this is quite urgent as it will ruin all the SEO of the website 🙁

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Have you asked the sitemap plugin developer for assistance? If the sitemap plugin is using get_permalink() for the post permalink & you don’t have redirect turned off in the DM settings, you should be getting the DM url.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    WHICH sitemaps plugin where you using? There’s a handful of them out there that work with multisite.

    For now just forget the sitemaps. I MUST restore the proper linking in the MENU and other autocreated links.

    This is the link to the site:
    Psychotherapy Online
    .

    As you can see the links in the menu, language selector etc. are bad 🙁

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    If you used a custom menu to create the navigation bar, then you *must* go back to the Menus area and fix your links.

    It’s the same as if you put links to other pages on the site within posts. Mapping the blog to a new domain will not fix every link it finds.

    I’ve used the WP3+ custom menus. The links are created automaticlly and I can not change them. And I use this template on many other sites and only this one got broken.

    I do not know exactly when it happened but it might be that after changing the Permalinks settings. I’ve set them back to the previous settings but it did not help. I really do not have any idea what have I done wrong 🙁

    I’ve just looked at the google cached copy and it looks as though I’ve not broken anything – the links were bad all the time and I just did not notice that.

    Anyway, I really like to fix that and, probably, that would also fix the sitemaps.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    It looks like you are running a language plugin and have the redirect to the primary domain turned off. The URLs will not be changed by the domain mapping plugin if the redirect is turned off.

    Is there anything I can do? I use WPML.

    I understand the words, but not the meaning 😉

    How can I “have the redirect to the primary domain turned on”?

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Is there anything I can do? I use WPML.

    I’ve never used it so I don’t know what your options are with it.

    How can I “have the redirect to the primary domain turned on”?

    That’s a checkbox in the Network admin Domain Mapping screen.

    You mean the “Disable primary domain check. Sites will not redirect to one domain name. May cause duplicate content issues.” checkbox.

    It’s off, so redirect to primary domain only is on.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    It’s off, so redirect to primary domain only is on.

    Actually, it’s off so redirect to primary domain is *off*.

    And the DM plugin is not filtering your menu item URLs because you’ve told it not to “redirect” those URLs to your mapped domain.

    how come?

    If I check to “Disable primary domain check.” then every mapped domain works. If it is off (not disabled) only the primary domain works.

    Anyway – the links are not “mapped”.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Actually, it’s off so redirect to primary domain is *off*.

    Sorry, had that backwards. You were correct. If you don’t have that checked, what is your primary domain/url?

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Also, have you tried turning WPML off to see what effect it has on the URLS?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Links are not mapped :(’ is closed to new replies.