Support » Plugin: WP eCommerce » links are broken

  • Resolved jnz31


    so i had this running, it worked well. until i edited pages and the menue..

    its my second install, on my first install the update is not running properly, in fact its doing the same thing.
    its a fresh install of wp 3.5 with the newest verion of wp e-commerce. also installed is Smart Manager for e-Commerce, WP e-Commerce – Printable Invoices, WP E-Commerce Premium Shipping & xcloner.
    the theme is by me, its a childtheme of twentyeleven, i modiefied some wpec files, but i worked with the files of and just changed some minor stuff (and it all worked). even if i delete these files i have the same errors.

    like i said, it all worked (kind of, the ajax add to cart thing was not acting completly right, but it was adding stuff, enough for me so far) the checkout was working with shipping and taxing.
    then i added some pages, with subpages of another page (NOT wpec) and edited the theme menue via appearance > menu.
    since then all links are broken. its 404 or it show the home page, while it should show the checkout f.ex.. i deleted the menu and the pages, but the error is still there.
    when i change the permalink structure to messy it works. when i change it back to some clean setting: error (yes, saved it twice). i didnt touch any php files since then and even before i only moded little stuff and it WORKED.

    now i deactivated wpec, changed the permalink structure to clean and everything works fine (the pages with the placeholders appear at the right spot) i put wpec back on and: tadah it works! ill add menue and pages again and report back.

Viewing 3 replies - 1 through 3 (of 3 total)
  • first i added the new menue.
    i have to check why this is not appearing on the site (didnt even work in the previous test, guess i have to change some minor thing, im no wordpress killa) but the site still was running fine.
    then i added the pages, which are subbpages of a page called information (NOT wpec related at all): error.

    de- and reactivated wpec: works.

    now this is some frustrating trail and error shit. but im happy it works now.

    i hadnt activate the menu as my primary menu. works fine now, too.

    and the ajax thing: i hadnt activate the “fancy notifications” as well.. i saw them on another site and was missing them here.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘links are broken’ is closed to new replies.