Support » Plugin: Amazon Associates Link Builder » Links and images doesn’t show at backend

  • Since some weeks, all my links and images, carrousels and all created with the plugin disappeared.

    I am not sure if it was caused by the WordPress updates. I tried too to rollback, and it stayed the same.

    Or maybe it is a problem with the plugin itself, with the API keys, or I don’t know. I can’t search for products, and also, the shortcodes I already had do nothing. No link, image or carrousel shows up at the website front end.

    I already tried also creating new API keys several times, and testing combinations from default marketplace, the marketplace where I got the API keys, and so. Of course I checked several times there was no extra spaces.

    I though it could be a geo-ip issue, but tried to delete de plugin and setupt it only with one amazon market, and it was the same.

    Could someone help me to get some light with this problem? I am also waiting for support reply.

    Also… I think there should be a way for the plugin to keep working (at least in some way) besides the API keys fail. At least, it could generate easily a basic link to the product without accessing the API. It only has to concat the url with the id and ASIN. That would avoid this happening (this is the second time this happens to me… and it really annoys me because I can be losing some sales at this moment with the links not showing).

    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 41 total)
  • Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @taisa1984,

    Please share the following details to help us to debug the issue:
    1. PHP error logs.
    2. PHP version (You can use plugins like display PHP version that display your PHP version on the WordPress dashboard)
    3. WordPress version.
    4. Plugin version.
    5. List of plugins installed on your system.
    6. Operating System version(OS version).
    7. Browser console log error generated at the time of the error. Steps to get the console logs:

    Open the Console window in Chrome using Ctrl + Shift + J (or Cmd + Opt + J on Mac) Follow this for reference.
    Hit the Save button and check the console log errors
    Send us the screenshot of console log as it is by sharing them using any 3rd party image sharing tool.

    Regarding plugin to keep working besides the API keys fail, this is not possible because item information(price, availability, image etc.) is fetched from the API itself. So it is necessary to have the API keys working.

    taisa1984

    (@taisa1984)

    Ok, checking all that, I think I found the problem. I changed to PHP 7.3 as it was suggested to use with the new version of WordPress. Now I changed back to 7.1 and it seems to work fine again.

    Lots of thanks, and sorry for the bothers.

    And without the API I think there could be at least a plain link, maybe no photo or price, but at least the links could work. This could also allow new affiliates to use the plugin, because they are not allowed to get API keys until the have some sales. I think you are interested in more people using the plugin… If they can not use the official, they could start using another one, and to change later is bothersome.

    taisa1984

    (@taisa1984)

    Umh. I think this is going to drive me crazy. It worked for a while, when I changed the PHP version. But now it is again not working (and I think I did nothing else afterwards).

    I tried again disabling all the plugins, and still the same.

    So here it is all the information.

    1. PHP error logs.
    I activated the option into my server, but no error file is generated or I can’t find it.

    2. PHP version (You can use plugins like display PHP version that display your PHP version on the WordPress dashboard)
    I had 7.3, changed to 7.1 and it seemed to work for a while. Afterwards, it stopped working again.
    Changing back and forth made nothing.

    3. WordPress version.
    5.0.3 (I also tried some weeks ago to rollback to 4.8 and didn’t work).

    4. Plugin version.
    1.8.0 (the last one)

    5. List of plugins installed on your system.
    Advanced Ads
    Amazon Associates Link Builder
    Amazon Link
    AMP
    Anti-spam
    Bloom
    Cookie Notice
    Download Manager
    Easy Table of Contents
    GeoIP Detection
    Glue for Yoast SEO & AMP
    Instagram Feed
    Metricool
    Monarch Plugin
    plugin load filter
    Redirection
    Smush
    UpdraftPlus – Backup/Restore
    Wordfence Security
    WordPress Editorial Calendar
    Yoast SEO

    6. Operating System version(OS version).
    My device? I work with W10, but also happens in my mobile phone with android. I am not sure this has anything to do.

    7. Browser console log error generated at the time of the error.
    The console shows no errors. (There is no visible error, simply, the shortcodes are not showing as links or images or anything at the front end.

    My guesses are that my API keys do not work, and “sometimes” they do. Or maybe the geo-location, but I also tried deleting one of the countries and didn’t work (I guess it should not affect when working only with one country), but the search doesn’t work either, so I am not sure.

    taisa1984

    (@taisa1984)

    Ok, this is really odd. I cloned my site on a test server… and there it worked, without touching anything… Completely cloned, all the same. So, what is happening in my domain that it doesn’t work there?

    taisa1984

    (@taisa1984)

    I am starting to think if it is related with the efficiency guidelines and limits… But it makes no sense. I receive at most 1000 visitors per day. And I am not sure that they visit more than one page. So I think they are not getting to the limit.
    (yeah, maybe there are some links in one page… but… Does it make a connection for each item?) Again, I think it should be best that the plugin doesn’t access the API each time it has to show a link or image for each visitor…

    Also… why my site links stops to show, and the clone not? Wouldn’t it be the same with the same API info? Or it is domain constrained maybe?

    That is the only viable explanation I see right now.

    I still have this problem.

    Here in my site, it doesn’t work.
    For example:
    https://www.lasaventurasdetaisa.com/manicura-laminas-miss-sophies/

    Here, in a cloned site, it does work.
    https://vz1gzkfkf8t.c.updraftclone.com/manicura-laminas-miss-sophies/

    I really want this solved, and I don’t know what else to check.

    I already contacted the hosting provider too. The already double checked the settings.

    It would be nice to have some answer or information here that helps me solve this.

    Hola buenas tardes, si resolviste tu problema? tengo exactamente el mismo.
    En que hosting estas alojada.

    I have the same problem but assumed it was Amazon being cruel to small business owners again.I put an awful lot of work into this – now look at this page – it had 3 book recommendations per month… Now it’s empty. I put 3 links on from the ‘old’ way (no API) to be sure it wasn’t a wordpress issue. Even the links from the API don’t work. A lot of work has gone into this API and now nothing shows…

    https://professionalshealthconnection.com/best-home-exercise-equipment/reading-of-the-month/
    here’s another one that used to show women’s gym attire:
    https://professionalshealthconnection.com/workout-clothes-2/activewear-for-women/

    before this happened, the API sporadically had missing images – then they would appear, then disappear – I was thinking there was a limit per page and that was one of my next Amazon issues to fix but I think the change they made on 1/23/2019 did this.
    I wrote them but haven’t heard back…I’m probably too small a business owner for them to change their approach…

    I don’t understand what could be happening.

    My host is one.com, but I tried in other of my domains, and there it worked. In the same domain, another webpage created in a subdomain doesn’t work. So… I started to think they filtered for any reason my domain. But they say it’s nothing like that.

    And the clone thing was amazing, bcause there it worked. Sadly it expired and I do not want to keep paying for it when nobody is going to take a look.

    And yes, we are so very small business for them to look to much into it, and also, they do not have a ticket system, so I have to explain all over again every time I contact them. 🙁 At least they contacted me, but only to say that I review everything again, and to send me the guidelines again and again.

    Also, I had other amazon links plugin too, and I thought I would go back to use it instead… but the APIs don’t work there either (again, only from this domain).

    So:
    The API keys work. The plugin with the same keys in other domains work. The plugin with the same keys in a clone from my domain work.
    The API keys from my website don’t work from any plugin. The API keys from another website in the same domain don’t work from any plugin.

    My sales were slowly going up since I have more visits, I had hight expectations for this year… till this happened. Now I am so upset… and I don’t know what else can be done.

    Uuumh… I am going to make a guess… Maybe they have a bug in the new code caused by the domain name lenght?? Joan’s domain is quite long too. Is that your case too, Gustavo?

    Gustavo, el nombre de tu dominio es también largo?

    para nada es: https://antiguomundo.com, según hoy lanzaron una versión 1.9.0 actualizare y les comento.
    Yo también me puse en contacto y lo que me respondieron fue: que no se pueden meter en mi código pero no moví nada de código ni antes ni después de que ya no se mostraran los productos.

    Bueno, pues vamos a probar a actualizar a ver qué pasa. Ojalá se solucione. Yo ya no descarto nada, pero esto es todo muy extraño.

    ya actualice y aún nada sigue sin funcionar. debe ser porque somos webs pequeñas, hay webs enormes que mantienen esos enlaces

    Si, entiendo que no a todo el mundo ha dejado de funcionarle, sino esto estaría hirviendo. El punto podría ser intentar ver qué tenemos en común para que justo a nosotros no nos funcione… Algo tiene que haber, no sólo el ser webs pequeñas, digo yo… Ya digo, a mí, la misma configuración en otras webs incluso más pequeñas me funciona.

    Tema de otros plugins no debería ser, porque yo ahora estoy probando en mi dominio, pero en otra instalación de wordpress mucho más limpia. Tema diferente, todavía en WP 4.9 y acabo de quitar todos los plugins menos los de amazon. He actualizado el plugin y nada (de hecho, ya digo, que no creo que sea cosa del plugin porque tengo otro que tampoco está funcionando).

    Maybe It could be a good idea to see what have we in common, to try to guess what is the problem.

    This is the only thing I see that could cause a problem… but, really, my site is so small, that makes no sense to think there are so many calls. unless the plugin is making more requests than it should …

    “Check how quickly your application is submitting requests.

    If your application is submitting requests faster than once per second per IP address, you may receive error messages from the Product Advertising API until you decrease the rate of your requests.”

    From the famous guidelines… https://docs.aws.amazon.com/es_es/AWSECommerceService/latest/DG/TroubleshootingApplications.html

    Anyways, I already told Amazon support, if that thing exists, there should be a way to check what is happening ourselves (how often are the calls happening, how many, and all that).

    Umh… What if, we use a hosting that hosts too larger websites that also use amazon API? If it is counted by IP, maybe they are counting too other calls that do not belong to us.

    I don’t know for sure, but I think that this is not really caused by something we did. But hey, here we are losing time and money :(.

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Links and images doesn’t show at backend’ is closed to new replies.