Support » How-To and Troubleshooting » Linking pages in the header

Linking pages in the header

  • Forgive my non techie message. I have just set up a wordpress blog. The template I have downloaded has four page icons on the header – Home – About – Contact – Links. I have worked out how to link the Home page by making the front page static however I cannot for the life of me work out how I make the other menu options link to pages on the blog.

    Any help would be greatly appreciated!

Viewing 5 replies - 1 through 5 (of 5 total)
  • pauper,

    Hi. You will most likely need to edit the hard-coded links in your theme’s header.php file. Do you have a link to your blog? If so please send. Also, do you have a link to an information page about the theme that you are using? If so, please send too:)


    Hi Mike, Thank you for the reply – Im sure you already know that was all double dutch to me lol but thank you anyway. The blog is http://www.surpriseletters.com


    Hi. If that was double Dutch to you – I think that the following might require adding a jump rope or two:)

    What is going on here is that the theme you downloaded ASSUMES that you are using permalinks and that the following urls work:


    Judging by the links in your sidebar – you do not have permalinks enabled. Please read Using Permalinks for more information about permalinks.

    What might work for you is this:
    Log into wordpress admin.
    Click “Options” from Navigation ber
    Click “Permalinks” from sub-Navigation bar.
    Under “Common options” choose “Date and name based”.
    Under “Optional” I have chosen a category base of “/news” (note: although this is optional – I have found that it works better to have a category base)
    Click “Update Permalink Structure”

    !!! At this point you may be asked to create a .htaccess file by copying and pasting the code that appears in a textarea box. If no box appaers – you should be good to go.

    No that your permalinks are set up – you can create your pages. Create pages with page slugs of: ‘about’, ‘links’ and ‘contact’ and your navigation should work like a charm.

    Hope this helps,

    I bow to your superior knowledge – thank you so much Mike – this has been frustrating me for days but thanks to you it is now fixed and working ! You are a genius!

    Thanks for the kind words:)
    Glad that this was helpful!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Linking pages in the header’ is closed to new replies.