Support » Plugin: Falang multilanguage for WordPress » Linking issue in Google Chrome

  • Resolved Q-collective

    (@q-collective)


    Hi there,

    I’m using Falang to setup a multilingual WordPress. My default is Dutch and added language is English. When “show slug for main language” is switched off, I have an issue in Google Chrome in that the main domain defaults to English anyhow. There is no way to switch to Dutch. I suspect this user was having the same issue. In Firefox everything works as expected.

    Now, it’s not a huge issue to have a /nl slug by default, but I do think there’s a bug going on somewhere. Can this be reproduced by the dev? If so, can it be solved?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author sbouey

    (@sbouey)

    Hi,

    Actually when you set the automatic detection you have to enabled the display default language slug.

    i have to improve Falang to allow automatic detection and hide slug for main languge but it’s need language cookie for that

    Stéphane

    Thread Starter Q-collective

    (@q-collective)

    Yeah, apparently I had English as the default language in Chrome. When setting it to Dutch, the website loads as expected. But this is of course an issue when people are unaware that they’ve set their website to English as default, and then being unable to switch to Dutch 🙂

    So, a proper solution would be good. A functional cookie seems fine if that is the route to take.

    Plugin Author sbouey

    (@sbouey)

    When in Falang Settings “Auto-detect language when language is not specified in url” is checked you need to have “Show slug for main language” checked too.

    It’s in the todolist to improve this feature.

    Stéphane

    Thread Starter Q-collective

    (@q-collective)

    That’s great to hear! I’ll work with the workaround for now. Hopefully this thread is useful for others. Thanks for your quick responses 🙂

    Plugin Author sbouey

    (@sbouey)

    Yhe problem was not chrome or firefox , i mark the thread as resolved.

    Other users asking me to improve this too.

    Have a nice day

    don’t forget to leave a review on Falang. Thanks

    Stéphane

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.