• Resolved davidedelmedico

    (@davidedelmedico)


    Hi,
    I’ve a sidebar that replaces main sidebar in homepage,
    when I add something in the Homepage sidebar, that is automatically added to generic (post, pages, taxonomy) sidebar,
    the same if I delete.
    So I can’t customize my sidebar in home with different contents. What this behavior means?
    PS. every widget in homepage sidebar hase a “link” symbol (the same as clicking clone) aside,

    Thank you in advance
    Dave

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter davidedelmedico

    (@davidedelmedico)

    Another thing I noticed is that, if I create a new sidebar for homepage,
    before associating that in “Sidebar Location” the behavior is the correct one, after I associate it to Front Page it drops generi sidebar content and replace it with new one

    Hello @davidedelmedico,

    I’m sorry to hear that our plugin is not working correctly on your site.

    Could you make a screenshot of your settings in Widgets so I can have a better understanding of what is happening?
    Please also tell me what theme you are using.

    kind regards,
    Kasia

    Thread Starter davidedelmedico

    (@davidedelmedico)

    Of course! Thank you in advance!

    https://drive.google.com/file/d/1z5HbT9BcQzs1KuZJkELBBeFiOZQivjUd/view?usp=sharing

    If I delete a widget from “/ – Sidebar”, it is removed from “Sidebar”,
    If I delete a widget from “Sidebar”, it is restored after a refresh,
    This happened after I configured / – Sidebar in this way:

    https://drive.google.com/file/d/1NyUAVwiFYFhhyqVMHQH0STo1Ug-XRZyW/view?usp=sharing

    When I activate Front Page option, link icons appear,

    Davide

    Thread Starter davidedelmedico

    (@davidedelmedico)

    Hello @davidedelmedico

    I hope you’re doing well!

    I’ve tested the Custom Sidebars plugin with the Poseidon theme and could not replicate this behavior.

    Would you please run a quick test for a conflict with another plugin?
    – Deactivate all the plugins besides the Custom Sidebars and see if this issue still occur
    – If all is well, please start activating one plugin at a time, to find the plugin what is causing this

    Let us know how it went!

    Kind regards,
    Nastia

    Thread Starter davidedelmedico

    (@davidedelmedico)

    Hi,
    I tested as below:

    I deactivated all plugins, result is: lost half of widgets.

    A part of those was in Inactive Widgets.

    I reactivated plugins to see if they go back to the right plase, result is: emplty Inactive Widgets and no widget restore.

    Right now I’ve no widget in the sidebar and if I add a widget tie behavior is the same: if I create a new One in a sidebar used in a specific place, the same widget is copied in the generic sidebar. With of without other plugins.

    I continue tests.

    Thread Starter davidedelmedico

    (@davidedelmedico)

    Little Update: i confirm that removing every plugin the situation is the same,
    a lot of widgets was removed because they come from plugins deactivated 😛

    Hello @davidedelmedic

    I trust you’re doing well!

    Please let me know what PHP version is enabled on your server? And what is the WordPress version?

    Would you please export the Sidebars setting from Appearance > Widget, as shown below?
    https://monosnap.com/file/CqSjQJqElG8ybDMJzXKSsFoE0wAMcL

    Please upload the exported file to the Google Drive and share a link in here.

    If the “/ – Sidebar” is renamed to something else, will this issue still occur?

    Looking forward to your reply!

    Kind regards,
    Nastia

    Thread Starter davidedelmedico

    (@davidedelmedico)

    PHP 7.1
    Wordpress 4.9.8 (I’m terrified by updating to 5.0 right now)

    https://drive.google.com/file/d/14rP6W251iPrIzTc1ojkOcEYln7vtgul4/view?usp=sharing

    The issue occured even with other name or other sidebar with Front Page option Activated (I tried to create a brand new sidebar, fill it and activate option “Front Page”, after this last step, widgets go crazy)

    Thank you again,
    Davide

    Thread Starter davidedelmedico

    (@davidedelmedico)

    I tried these names for the new sidebar (renaming it and refreshing):
    Home – Sidebar: no error
    Homepage – Sidebar: error
    / – Sidebar: error
    [/] Sidebar: error
    /H – Sidebar: no error

    could the name management be responsible?

    EDIT:
    after few tests more, I discovered this:
    it’s true, if I rename any sidebar to one of these “bad” names,
    seems to be an issue in showing widgets
    (if I rename back the sidebar, content of widgets will be restored)

    I tried renaming casual sidebars to bad names, and every time the main sidebar is overwritten

    There is some escape menchanism that converts “/ – Sidebar” in “Sidebar”?? some trim() or similar??

    • This reply was modified 5 years, 6 months ago by davidedelmedico. Reason: further info

    Hi @davidedelmedico,

    Sorry for the delay here.

    We did multiple tests on multiple installations but none of us were able to replicate the issue you are having.
    Could you contact us with screenshots of your settings for Widgets and your post and page sidebar settings so we can try and recreate the similar setup on our end?

    You can contact us directly by using our contact form here:
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: “Attn: Predrag Dubajic”
    – Link to your WordPress site
    – Link back to this thread for reference
    – Any other relevant urls

    Cheers,
    Predrag

    Thread Starter davidedelmedico

    (@davidedelmedico)

    OK! Thank you!

    Davide

    Hello @davidedelmedico

    Hope all is well!

    We’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Have a good day and take care!

    Cheers,
    Nastia

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Linked sidebars with no reason’ is closed to new replies.