WordPress.org

Forums

WooCommerce - excelling eCommerce
Linked and Related product fields not working since update (6 posts)

  1. zwaan
    Member
    Posted 1 year ago #

    Hello! The Linked Products and Related products fields on the back end worked before and I was able to add linked and related products, but since the update these two fields are:
    - very narrow horizontally
    - when I type in the field only the middle part of the text shows, top and bottom are cut off
    - it used to suggest items as I started typing, now it can't find words that are most definitely shown in other product titles.

    The linked and related items that were already entered on older product listings are still there, but I am not able to add any to older products or to new products, same problems as above.

    I tried searching for the answer and couldn't find anything, tried the site inspector and can't tell if it's a CSS or php change, I hope someone has a suggestion!
    Thanks!

    https://wordpress.org/plugins/woocommerce/

  2. Daniel Espinoza
    Member
    Posted 1 year ago #

    Post a URL to your site and someone can take a look.

    Check your admin pages for javascript errors; that may block the ajax call for product name searches.

  3. zwaan
    Member
    Posted 1 year ago #

    Thanks for replying!
    Sorry, I meant on the backend, when I'm entering Up-sells and Cross-sells for a new product. Does anyone know if this feature has been removed from the Woocommerce update?

    These are 2 things I noticed in the HTML for the backend that seemed like they might be clues (shown in larger HTML context below):

    style="width: NaNpx;"
    style="width: 0px;" autocomplete="off"

    ...and this is from the CSS that's showing in the site inspector for the Up-sells and Cross-sells input boxes:
    element {
    width: 0px;
    }

    //***HTML***//
    <p class="form-field">
        <label for="crosssell_ids"></label>
        <select id="crosssell_ids" class="ajax_chosen_select_products chzn-done" data-placeholder="Search for a product…" multiple="multiple" name="crosssell_ids[]" style="display: none;"></select>
        <div id="crosssell_ids_chzn" class="chzn-container chzn-container-multi" style="width: NaNpx;" title="">
            <ul class="chzn-choices">
                <li class="search-field">
                    <input class="default" type="text" style="width: 0px;" autocomplete="off" value="Search for a product…"></input>
    
            <div class="chzn-drop"></div>
        </div>
    </p>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

  4. popgirl23
    Member
    Posted 1 year ago #

    Im having a similar issue but with the editing coupons.

    With the theme I want to use I see all the "chzn-container" & "chzn-choices" but when switching to a default theme (twentyfourteen), I see "chosen-container" & "Chosen-choices".

    Ive also simply tried overriding the inline style of the input text box to 40px but still doesn't work.

    Havent solved it yet. Help?

  5. popgirl23
    Member
    Posted 1 year ago #

    Zwaan,

    I was able to fix a very similar issue by updating a couple of jquery chosen files provided to me by my theme developer.

    Im not a js developer myself so Im afraid my info here is only basic, but I can tell you that the newest woo is not fully compatible with the latest jquery chosen. (http://harvesthq.github.io/chosen/)

    It appears you theme has chosen bundled within it as I can see class & Id's using "chzn" versus "chosen" in your code. That might be a direction to look into.

  6. vborges
    Member
    Posted 9 months ago #

    I am having the exact same issue as Zwaan. Has anyone been able to find a fix for it yet? I tried updating jquery chosen as suggested by popgirl23, but to no avail...

    Any help would be appreciated! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic