WordPress.org

Support

Support » How-To and Troubleshooting » Linkcategory did not merge with Category Table !

Linkcategory did not merge with Category Table !

  • Sr-ultimate
    Member

    @sr-ultimate

    Hello,

    I had upgraded to 2.2 a month ago but it did not get upgraded properly. I mean the category/link category table has problems.

    For e.g
    When I login to Admin Panel > Link manager , I get a lot of error, like

    WordPress database error: [Table sreejith_wrdp1.wp_link2cat doesn’t exist]
    SELECT category_id FROM wp_link2cat WHERE link_id = 29 ORDER BY category_id

    When I write a post I cannot select category, there is a error in the category selection box.

    WordPress database error: [Unknown column ‘link_count’ in ‘where clause’]
    SELECT cat_ID FROM wp_categories WHERE category_parent = 0 AND ( link_count = 0 OR category_count != 0 OR ( link_count = 0 AND category_count = 0 ) ) ORDER BY category_count DESC

    Can anyone help me out ?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Sr-ultimate
    Member

    @sr-ultimate

    Any Help ??? please !!

    Sr-ultimate
    Member

    @sr-ultimate

    bump

    And did you try to rerun the upgrade? Or to upgrade to 2.2.1?

    Sr-ultimate
    Member

    @sr-ultimate

    Yes , after this error, I ran the upgrade.php few times but nothing . I also tried to re-upload all the files and then upgrade but nothing. Unfortunately , I dont have a backup.

    I believe that wordpress has merged linkcategories into category. Is that so ?
    I just wanted to know what all had changed in the update and how to merge the linkcat files into cat table.

    I would appreciate any help. Thanks

    1) RE the MySQL errors: Switch your theme to the default classic or kubrick. Do you still get the errors above?

    My best guess is your theme isn’t compatible with 2.2.

    2) Blogroll (links) seems to have changed in 2.x and there’s plenty questions and answers about it.

    Sr-ultimate
    Member

    @sr-ultimate

    1. What does theme have to do with this ? I am getting errors in my admin panel , “Write Post” “Link Manager” etc.
    Anyway I tried but nothing.

    2. I did not get you here

    Sr-ultimate
    Member

    @sr-ultimate

    Anyone? I really need this and don’t know where else to ask 🙁

    Sr-ultimate
    Member

    @sr-ultimate

    Helloooooo

    Sr-ultimate
    Member

    @sr-ultimate

    I guess I won’t be getting any help here

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Linkcategory did not merge with Category Table !’ is closed to new replies.