Support » Plugin: Facebook » Link your Facebook account to your WordPress-not enabling?

Viewing 15 replies - 31 through 45 (of 79 total)
  • nida78

    (@nida78)

    3.1.4

    silentbeauty

    (@silentbeauty)

    I’m using WP 3.4.

    katiektk

    (@katiektk)

    Having same error as OP.

    app ID: 433110150042908

    App Namespace: healthy-nutrition-ex
    Site URL: http://www.healthynutritionexpert.com/
    Site Domain: healthynutritionexpert.com

    Thanks for your help,

    Katie

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    joymccambridge:
    “I have been trying to set up the social publisher, but when I click Link your Facebook account to your WordPress account to enable it isnt..um.. enabling 🙂
    The facebook window open, but it doesn’t complete the action
    Any help would be appreciated.”

    Can you post a screenshot of what happens?

    Can you clarify “but it doesn’t complete the action”?

    Also, please try 1.0.1, which includes a bunch of bug fixes and let me know if this is still a problem.

    Thanks

    dnoe

    (@dnoe)

    @matt,

    I upgraded to the latest version, and it still doesn’t work. Now when I make a new post, upon trying to publish it… I get an error. The article still publishes, but nothing is posted to facebook. Here is the error (edited to hide my username)

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/username/public_html/wp-content/plugins/facebook/fb-social-publisher.php on line 485

    Warning: Cannot modify header information – headers already sent by (output started at /home/username/public_html/wp-content/plugins/facebook/fb-social-publisher.php:485) in /home/username/public_html/wp-includes/pluggable.php on line 881

    ALL other plugins are disabled, and I am using the latest version of WP.

    Igloozion

    (@igloozion)

    WordPress Version 3.4
    (Jetpack version 1.4.2)

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    @dnoe: Can you edit that code? Try changing it to

    if ( isset( $existing_status_messages ) && is_array( $existing_status_messages ) ) {

    Let me know if that fixes it and we’ll push a fix. Thanks

    AUDIOMIND

    (@audiomind)

    3.2.1 Here…

    It’s simply that the link to connect leads nowhere….

    See it here:
    http://i49.tinypic.com/29mkw2v.jpg

    FB Link is highlighted red in bottom left.

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    @audiomind: it uses an onclick event. Can you open the developer console? Do you see any JavaScript errors? Thanks

    katiektk

    (@katiektk)

    I updated to the newer plug in version and now when I click the “Link your Facebook account to your wordpress account” I get the following right at the bottom of the screen (clicking the link doesn’t do anything):

    “debug info
    {“appid”:”433110150042908″,”version”:”1.0″,”domain”:”www.healthynutritionexpert.com”,”social_publisher”:{“enabled”:”true”,”publish_to_authors_facebook_timeline”:”true”,”mentions_show_on_homepage”:”true”,”mentions_position”:”both”,”publish_to_fan_page”:[]},”recommendations_bar”:{“enabled”:”true”,”trigger”:”50″,”read_time”:”20″,”action”:”like”,”side”:”right”},”subscribe”:{“enabled”:”true”,”layout”:”standard”,”width”:”250″,”show_faces”:”true”,”colorscheme”:”light”,”font”:”arial”,”position”:”both”,”show_on_homepage”:”true”},”comments”:{“enabled”:”true”,”num_posts”:”20″,”width”:”470″,”colorscheme”:”light”},”send”:{“enabled”:”true”,”colorscheme”:”light”,”font”:”arial”,”position”:”both”,”show_on_homepage”:”true”},”wp_ver”:”3.2.1″}”

    sarahl

    (@sarahl)

    same problem with social publisher

    app id: 243251932456735
    namespace: sarahscyprus

    sarahl

    (@sarahl)

    keep getting this error, even though I reactivate it every 5 minutes:
    To reactivate publishing, visit the Facebook settings page and re-enable the “Publish to fan page” setting. Full error: {“message”:”Error validating access token: Session has expired at unix time 1340287200. The current unix time is 1340287355.”,”type”:”OAuthException”}

    fionadruce

    (@fionadruce)

    @dnoe, I’d love to know if that worked. I have the exact same problem. Disabled all plug-ins, updated the FB plug-in and WP.

    Same problem right here on WP 3.2.1, driving me buggy!!!

    app id: 317881308306624
    namespace: clear-path-institute
    domain: clearpathinstitute.com

    I have tried entering the URL with and without the www and nothing seems to work! It’s good to know I’m not the only one having this issue, but I wish someone would tell us what the fix is!!! Thanks!!

    I do notice an “Error on page” message in the lower left hand corner and when I open it up, here are the error details it gives me:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; FunWebProducts; GTB7.3; .NET CLR 2.0.50727; .NET CLR 1.1.4322; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; InfoPath.2)
    Timestamp: Tue, 3 Jul 2012 16:32:53 UTC

    Message: ‘FB’ is undefined
    Line: 15
    Char: 2
    Code: 0
    URI: http://clearpathinstitute.com/wp-content/plugins/facebook/scripts/fb-admin.js?ver=1.0

    Message: ‘FB’ is undefined
    Line: 15
    Char: 2
    Code: 0
    URI: http://clearpathinstitute.com/wp-content/plugins/facebook/scripts/fb-admin.js?ver=1.0

    mattkelly

    (@matthwkgmailcom)

    @timelymanner1 thanks, helpful.

    It looks like your installation of WordPress isn’t loading the footer properly.

    Can anyone on this thread that’s having problems debug PHP? 🙂

Viewing 15 replies - 31 through 45 (of 79 total)
  • The topic ‘Link your Facebook account to your WordPress-not enabling?’ is closed to new replies.