Support » Plugin: Best WordPress Gallery Plugin – FooGallery » Link to full size image not working

  • Resolved stevethefootycoach

    (@stevethefootycoach)


    I have several galleries on this site and they are affected in the same way – when I click on a thumbnail in a gallery, expecting a full size image to pop up, nothing happens.

    The galleries are set up correctly, I think

    Gallery settings

    I have tried deactivating plugins one by one and can’t find a conflict.

    Can you suggest a way to fix this?

    Many thanks

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author bradvin

    (@bradvin)

    hi @stevethefootycoach

    There is an error in the javascript, but it is hard to see from where, as all the scripts are being combined and minified. Can you disable your cache/minify plugin temporarily? That will help us track down the problem

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    Hi.

    Thanks for getting back to me.

    I’ve disabled caching and minification as requested.

    Plugin Author bradvin

    (@bradvin)

    thanks @stevethefootycoach

    Are you using a plugin to alter all your site’s javascript includes? Something to do with PageSpeed Service?

    We are noticing that all the script tags in the markup are set to type=”text/psajs”

    Googling around, it seems that is no longer supported since 2015 : https://developers.google.com/speed/pagespeed/service/DeferJavaScript

    Please can you disable the plugin doing this, or disable the setting that is doing this

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    Thanks.

    I’m not using any plugins that have anything to do with PageSpeed Service.

    I’ve asked my hosting company if it’s anything server side.

    I’ll get back to you as soon as I find out.

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    This is at the bottom of the page:

    —-

    <script src="https://broughtongirlsfooty.co.uk/wp-includes/js/hoverintent-js.min.js,qver==2.2.1+admin-bar.min.js,qver==5.8+wp-embed.min.js,qver==5.8.pagespeed.jc.lYHTAGTLWG.js" type="text/psajs" data-pagespeed-orig-index="14"></script><script type="text/psajs" data-pagespeed-orig-index="15">eval(mod_pagespeed_2aq7PgZJkk);</script>
    <script type="text/psajs" data-pagespeed-orig-index="16">eval(mod_pagespeed_yYEu4_P5nV);</script>
    <script type="text/psajs" data-pagespeed-orig-index="17">eval(mod_pagespeed_N7RxrBJ3EU);</script>
    <script id='foogallery-core-js-before' type="text/psajs" data-pagespeed-orig-index="18">var FooGallery_il8n=[];</script>
    <script src='https://broughtongirlsfooty.co.uk/wp-content/plugins/foogallery/extensions/default-templates/shared/js/foogallery.js,qver=2.0.39.pagespeed.jm.eAcBVi0_vw.js' id='foogallery-core-js' type="text/psajs" data-pagespeed-orig-index="19"></script>
    	<script type="text/psajs" data-pagespeed-orig-index="20">/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);</script>
    	
    	<script type="text/javascript" src="/pagespeed_static/js_defer.I4cHjq6EEP.js"></script></body>
    </html>

    —–

    Is it Google PageSpeed?
    I don’t recall ever signing up to that service!

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    It’s fixed now.

    I’ve deleted the relevant CNAME record and the gallery works just fine again.

    Thanks for your help 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Link to full size image not working’ is closed to new replies.