WordPress.org

Support

Support » How-To and Troubleshooting » Link to attachment does not show when article read from category

Link to attachment does not show when article read from category

  • steghe
    Member

    @steghe

    Hy all,

    Here’s my problem with WP 3.4.2

    I post an article with an attachment

    http://albinoleffe2002.altervista.org

    The article pops up in the home page and the link to the attachment is there and it’s working.

    The same article is reachable through the Calendario category

    http://albinoleffe2002.altervista.org/?cat=7

    but the link to the attachment does not show!

    This problem happens with many themes (for example Twenty ten)
    but not with Twenty eleven.

    Any idea?
    What’s the patch to the theme?

Viewing 5 replies - 1 through 5 (of 5 total)
  • OurWebSupport
    Member

    @ourwebsupport

    Hi Steghe.. I would like to help you with this. I need some more information. What theme are you using? When you say “attachment” do you mean an image you want be able to see in your post?

    steghe
    Member

    @steghe

    The attachment is a file. I just want the reader to be able
    to download the file

    If you go to

    http://albinoleffe2002.altervista.org

    you can see the link to the file is working and can be downloaded

    If you go to

    http://albinoleffe2002.altervista.org/?cat=7

    ..the same article and the link the file is not working (not clickable)

    The theme is “atheros”
    With the theme “twenty eleven” the problem is gone
    With the theme “twenty ten” the problem is there againg

    Thankyou

    steghe
    Member

    @steghe

    …it seems that every html formatting is being removed also.

    If i put an html table it appears correctly in home page but it become plain text under caterogies

    TCBarrett
    Member

    @tcbarrett

    The home page is showing full post content, whilst the category is showing the excerpt.

    steghe
    Member

    @steghe

    Thank you, you are right.
    If i click on “continue reading” i see all the original article.

    Thanks again

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Link to attachment does not show when article read from category’ is closed to new replies.