WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Link to another language isn't working

[Resolved] Link to another language isn't working

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Dennis Ploetner

    @realloc

    @jonathanfokker Which version is installed? Do you have more then one admin for these sites?

    Cheers,
    Dennis.

    I do have WordPress 3.5.1.
    Plugin version 0.9.8.1

    Yes, I do have 2 super admins for these sites. Is that a problem?

    Thanks for you help!

    Greetings,
    Jonathan

    Plugin Author Dennis Ploetner

    @realloc

    No … or better it depends ;). Please have a look here for a quick solution:

    http://wordpress.org/support/topic/doesnt-detect-the-different-sites?replies=14#post-3833104

    This will be no problem in future versions because I will let the users choose the admin to consider.

    Cheers,
    Dennis.

    I’m having a similar problem. I have two sites one English and one Spanish. The link on the sites now has both “Read this page in English” and “Read this page in Spanish”. However, only the one for the opposite language actually brings you to the other site. For example, if I’m on the English site and I click “read this page in English” I’m then taken to the Spanish version.

    I have tried uninstalling and reinstalling the plugin. I’ve also added the language files to their own file under Wp-content folder.

    I am the only admin on the site. I have wordpress version 3.5.1 and MultiSite Language switcher I just downloaded on Monday, so I assume it is the most recent version.

    How do I fix it?

    So actually the double link is only showing up on one of the pages. On all the other pages it shows up as just one link, which links back to the page you’re already on.

    Plugin Author Dennis Ploetner

    @realloc

    That’s strange. Could you please double-check your settings? Do you have a link for me where I can see this?

    Thanks for getting back to me.

    I have the settings as follows:
    I am only displaying the description.
    The only radio box I have checked is the “Display link to the current language”
    I have the Hint priority set to 100.

    Here is the Spanish site: http://word.ica-peru.org/avanza-peru/
    Here is the English site: http://word.ica-peru.org/en/avanza-peru/

    I installed Native Dashboard because someone on one of the forums said that the language switcher worked after they installed it. However, that has not seemed to do anything.

    Also in my general settings the only language choices I have are English and Malay.

    Thanks!

    Plugin Author Dennis Ploetner

    @realloc

    Thanks for the links.

    Seems that you set in the settings of the Multisite Language Switcher “Read this page in English” in the Spanish blog and “Lee está página en Espanol” in the English blog. You should switch that because it is rather a label for the language of these sites.

    Cheers,
    Dennis.

    He Dennis,

    I tried to put the function on the website for the workaround, but didn’t work.
    I also changed one of my super admins to editors for all my websites, but still no luck.

    Any other ideas?

    Greetings,
    Jonathan

    Plugin Author Dennis Ploetner

    @realloc

    You should check the IDs of your blogs first. The example-function uses 1 and 2 which is maybe not true.

    I did a check. In my set up I have three websites.

    1) Network/holder which functions as a automatic redirect to EN or NL site depended on the browser language
    2) English website
    3) Dutch website

    In my blogs.dir I have two folders, named 2 and 4. These are the ID’s of the sites, aren’t they?

    With the 2 and 4 in the function, still not working.

    Jonathan

    Plugin Author Dennis Ploetner

    @realloc

    Yes, these are the IDs of the websites. It’s difficult to say what’s going on without seeing the backend and the settings. If you’d like that I check your setup you can send me a login for your website…

    Would be great if you can have a look. Where can I send FTP to? Which email address?

    Plugin Author Dennis Ploetner

    @realloc

    I think a login to your wp-admin will be enough. My email-address is re@lloc.de.

    Cheers,
    Dennis.

    Hey Dennis!

    I switched the two labels and then unchecked the show link to this page and then everything started working perfectly.

    Thanks so much for your help!

    Maryann

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Link to another language isn't working’ is closed to new replies.