WordPress.org

Forums

Multilingual Press
[resolved] Link only to homepage rather than corresponding page... (11 posts)

  1. vfmb
    Member
    Posted 10 months ago #

    Hi - I have your widget running on two networks (total of 4 sites) and on both networks the widget links back to the homepage of the other language only. I want it to switch to the corresponding page in the other language - have I missed something?

    many thanks

    https://wordpress.org/plugins/multilingual-press/

  2. toscho
    Member
    Plugin Author

    Posted 10 months ago #

    Hi,

    are the sites connected with each other correctly? Are languages assigned to all of them? See Network Admin/Sites/Edit/Multilingual Press.

    Are the translations all public, and do they show up in the post editor?

  3. vfmb
    Member
    Posted 10 months ago #

  4. vfmb
    Member
    Posted 10 months ago #

    I have the vbTranslations one working now - most of it at least - the posts pages don't want to link though…

    With the Ulrichwien site, I don't actually think I linked the pages to one another properly actually - my mistake. I need to re-work this site in any case.

    So the only open issue is the posts page link on vbtranslations.com…

    many thanks

  5. toscho
    Member
    Plugin Author

    Posted 10 months ago #

    Can you tell me the exact URL please? If it is an archive page – we don’t connect those currently. This is planned but not yet implemented.

  6. vfmb
    Member
    Posted 10 months ago #

    I want to link e.g. this

    http://vbtranslations.com/english-q-and-a/

    to this

    http://de.vbtranslations.com/englisch-qa/

    the individual posts link OK - its just the main posts page that I am having trouble with…
    its possible (I fear) that I missed the linking them element when I created them… can I do this now? or do I need to recreate the pages?

  7. toscho
    Member
    Plugin Author

    Posted 10 months ago #

    Changing and creating relationships later is a feature of our pro version. This is not possible in the free version, sorry.

  8. vfmb
    Member
    Posted 10 months ago #

    I have a feeling I have the pro version - how can I tell? although I have never got the Media library element to work properly….

  9. toscho
    Member
    Plugin Author

    Posted 10 months ago #

    The pro version says Multilingual Press Pro on the plugins listing page, and you have a settings page under Network Admin/Settings/Multilingual Press.

  10. vfmb
    Member
    Posted 10 months ago #

    Hi - so now I have definitely got the pro version on the vbTranslations site - and I've even recreated the posts page (English Q&A) like I thought would do the trick, but the two pages are still not linking.. so it is officially the 'posts' page that is notlinking - the actual posts and all other pages are fine, just the general posts page…

    http://vbtranslations.com/english-qa/

    should link to

    http://de.vbtranslations.com/englisch-qa/

    thanks

  11. toscho
    Member
    Plugin Author

    Posted 9 months ago #

    Have you tried the relink feature underneath the translator? If that doesn’t work, create a private topic in our pro support forum, and add log-in information for your site there. I will take a look then.

Reply

You must log in to post.

About this Plugin

  • Multilingual Press
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.