Support » Plugin: Yoast Duplicate Post » Link on top admin menu disappears for regular users

  • Resolved paulallison

    (@paulallison)


    I’m trying to solve a problem with some users not able to see the “Copy to a new draft” link in the top, black menu. Admins and Teachers can see it, but regular users (authors) cannot on any BuddyPress Doc.
    My question:
    Why does the Yoast Duplicate Post link (Copy to a new draft) appear in the top right of the black admin menu at the top of a Doc — for admins — but that same Duplicate Post link does not appear for regular (Author) users?
    Is there a permissions setting for this menu bar where we could give permission to regular users (authors) access to the duplicate button?

    The author role already has this access on other types of posts — e.g. pages and post. And, yes, we did check Docs in the list of items to allow duplication for.

    Any help on this?

    • This topic was modified 1 year, 2 months ago by .

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi @paulallison

    We understand that you are unable to locate the ‘copy to a new draft’ link in the admin bar menu at the top for authors, and you’ve already ensured that the author role is allowed to copy and that you’ve enabled BuddyPress Documents as a valid post type to copy in the Permissions tab settings of Duplicate Post.

    If you go to your WP admin dashboard > Settings (sidebar) > Duplicate Post > Display Tab, do you also have the ‘Show Links In’ section settings configured properly? Please make sure that ‘Admin bar’ is included and save the changes.

    Would it be possible for you to also provide us with some screenshots of the settings you currently have configured in the Duplicate Post menu so we can further understand this?

    Thread Starter paulallison

    (@paulallison)

    The Yoast “Copy to a new draft” link shows up on the toolbar on posts and pages for regular users / “authors” and for admins and teachers.
    The problem comes on any Buddypress Doc, On this page, for example: https://www.youthvoices.live/docs/agree-disagree-response/
    Admin user: “Copy to a new draft” shows up on the toolbar
    Author user: “Copy to a new draft” is not there.
    I need help to find what permission are not on for the author role for Buddypress file types.
    I’ve tried to be as clear as possible with this. Is the problem clear?
    I have attached images with annotations.
    The next things I checked in Settings > Duplicate Post:
    Admin bar is checked under display
    Author is checked under Permissions
    Docs is checked under What to copy.
    The only thing left is some sort of permissions somewhere for the “toolbar” or the “admin menu” that are not giving permission to the Author role.
    This is a puzzle! HELP.
    Screenshots with annotations

    Thread Starter paulallison

    (@paulallison)

    Call off the infantry!
    We found the permission and it works now.
    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Link on top admin menu disappears for regular users’ is closed to new replies.