WordPress.org

Support

Support » Plugins and Hacks » Link not working properly

Link not working properly

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Drew Jaynes

    @drewapicture

    Docs Czar

    Hi there. Sorry you’re having problems.

    I saved the permalink settings as suggested in previous posts to no avail.

    From the link you provided, I can see that you have your permalinks set on the default, which is to say, that “permalinks” are currently disabled on your site.

    However, the shortcode should still generate a valid download URL despite not using permalinks. The link URL the shortcode should generate is the following: http://boundlessriver.com/wp-content/force-download.php?file=uploads/Silent Memories.pdf

    So that said, let’s see if we can’t figure out what else is going on here. Can you tell me what if any other plugins you have activated are? Have you tried deactivating all of them except Download Shortcode? Have you tried enabling permalinks and saving them?

    Hey there, thanks for the speedy reply! So I enabled permalinks and the download link is now slightly changed when I click it, but still not functioning properly. Clicking the download text now directs to: http://boundlessriver.com/download/http://www.boundlessriver.com/wp-content/uploads/Silent%20Memories.pdf which is edging a little closer it seems to what is actually supposed to download.

    I’m currently using:
    *Google Doc Embedder
    *About.Me
    *Kebo Twitter Feed

    I tried disabling all of them except Force Download Shortcode, but that didn’t seem to fix anything. Thanks again for all your help with this!

    Plugin Author Drew Jaynes

    @drewapicture

    Docs Czar

    To be honest, I’m a little stumped. Essentially what’s happening is that the full media URL is being injected instead of the relative path.

    So for instance, it’s currently generating the following URL:
    http://boundlessriver.com/download/http://www.boundlessriver.com/wp-content/uploads/Silent%20Memories.pdf

    The “http://boundlessriver.com/wp-content/” part in the middle is the issue.

    The URL should actually be generated as this (which works):
    http://boundlessriver.com/download/Silent%20Memories.pdf

    So, moving forward. I may need to take a closer look at your setup, as well as possibly give you a development version that should provide more helpful information that I could use to diagnose your set up.

    If you’re interested in that, send me an email at drew (at) drewapicture.com and I’ll do my best to get this resolved for you.

    Hi Drew,

    I guess I am having similar issue with my implementation.

    You can view the page here:
    http://btct.tly.sg/happenings-around-us/test-force-download/

    The link that uses Shortcode is the New Link. The code behind it is [download label=”New Link”]http://btct.tly.sg/assets/1-Net-Managed-Services.pdf[/download]

    The link it generates is “http://btct.tly.sg/download/http://btct.tly.sg/assets/1-Net-Managed-Services.pdf” which will be a blank page.

    Please help.

    Thank you!

    Hi Drew,

    Exact Same issue here on a site with pretty permalinks. The page I have the shortcode on is a private page at:

    http://www.davidridgeway.co.uk/wordpress/download-shortcode-test-page.html

    but when it is clicked it tries to take you to:

    [audio src="http://www.davidridgeway.co.uk/wordpress/download/http://http://davidridgeway.co.uk/wordpress/wp-content/uploads/01-Relaxation.mp3" /]

    I have:

    flushed permalinks
    deactivated all other plugins
    Checked that forced-download.php is in wp-content folder

    All to no avail. Any help here would be great, your plugin seems to fit an essential need of this site, one I’d like to employ a lot more, but I’m really struggling to get it to work.

    Cheers!

    Plugin Author Drew Jaynes

    @drewapicture

    Docs Czar

    Hi ciaran12,

    Would you mind making your own thread so I can help you troubleshoot separately?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Link not working properly’ is closed to new replies.