Support » Plugin: WP Store Locator » Link “More info” not working

  • gato0815

    (@gato0815)


    Hello,
    thank you for this nice an good plugin.

    I have a problem, i can not click the “more info” link.

    Please can you help me?

    Regards

    Martin

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Tijmen Smit

    (@tijmensmit)

    Did you change anything in the code / templates?

    If you for a second disable all other plugins, does that make a difference? There might be a conflict with another JS script, and the only way to rule that out is by disabling all other plugins for a second.

    You can as an alternative just enable the ‘Always show the contact details below the address in the search results?’ option on the WPSL settings page.

    Thread Starter gato0815

    (@gato0815)

    The Problem is the Borlabs Cookie plugin.

    If i wrap the wpsl shortcode with:

    [borlabs_cookie_blocked_content type=”wpstorelocator”][wpsl][/borlabs_cookie_blocked_content]

    The “more info” not works.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    Thanks for letting me know, I will look into why that breaks it. In the mean time you can enable the ‘Always show the contact details below the address in the search results?’ option on the WPSL settings page to make all the details show up anyway.

    Thread Starter gato0815

    (@gato0815)

    The “Always show the contact details” is enabled. But they don`t show the Text of more Info.

    Hi there,

    I am having the same issue. Tried implementing the Borlabs Code in two different styles …

    [borlabs-cookie id="wpstorelocator" type="content-blocker"][wpsl][/borlabs-cookie]
    and
    [borlabs_cookie_blocked_content type="wpstorelocator"][wpsl][/borlabs_cookie_blocked_content]

    … but both ways I cannot klick on “more info” and also the markers are not “hopping” anymore. Also tried activating and deactivating the “GDPR – Only load Google Maps after the user agrees to it?” option, but no improvement…

    The following error in console appears …

    ReferenceError: InfoBox is not definedwpsl-gmap.min.js:1:1169
        M https://www.[removed].de/wp-content/plugins/wp-store-locator/js/wpsl-gmap.min.js?ver=2.2.232:1
        init https://www.[removed].de/wp-content/plugins/wp-store-locator/js/wpsl-gmap.min.js?ver=2.2.232:1
        e https://www.[removed].de/wp-content/plugins/wp-store-locator/js/wpsl-gmap.min.js?ver=2.2.232:1
        jQuery 2
        e https://www.[removed].de/wp-content/plugins/wp-store-locator/js/wpsl-gmap.min.js?ver=2.2.232:1

    … which can be solved by enabling “Use the default style for the info window?”. But still the more info cannot be expanded.

    As soon as I remove the sourrounding Borlabs shortcode everything works fine. It might has something to do with the correct order of loading the scripts implemented in wpsl shortcode?

    Can you provide a solution for this issue?

    • This reply was modified 1 year, 6 months ago by Ben.
    • This reply was modified 1 year, 6 months ago by Ben.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Link “More info” not working’ is closed to new replies.