WordPress.org

Support

Support » Plugins and Hacks » Link Library Version 4.2.6 problem!

Link Library Version 4.2.6 problem!

  • cinemaminima

    @cinemaminima

    I have just upgraded Link Library to version 4.2.6, using WordPress 3.0.1 automatic upgrade panel.

    This message is returned at the top of the Dashboard:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /path-to/wp-content/plugins/link-library/link-library.php:1) in /path-to/wp-content/plugins/si-contact-form/si-contact-form.php on line 1115

    And on the public Web pages:

    Warning: Cannot modify header information - headers already sent by (output started at /path-to/wp-content/plugins/link-library/link-library.php:1) in /path-to/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 69

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /path-to/wp-content/plugins/link-library/link-library.php:1) in /path-to/wp-content/plugins/si-contact-form/si-contact-form.php on line 1115

Viewing 15 replies - 1 through 15 (of 19 total)
  • TheGraciousPantry

    @thegraciouspantry

    I just upgraded it as well (like 20 minutes ago) and now I get this warning:

    Warning: Cannot modify header information – headers already sent by
    (output started at…

    No matter where I go in my blog, this warning pops up.

    HELP!!!! My readers really depend on this plugin!

    Tiffany @ The Gracious Pantry

    adminbsd

    @adminbsd

    Same here!

    Warning: Cannot modify header information – headers already sent by
    (output started at…

    Page not loading 404 error…

    christian-s

    @christian-s

    I’m also getting various errors, like
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 890

    and when I log off I get a page with

    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-login.php on line 337
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-login.php on line 349
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 717
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 718
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 719
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 720
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 721
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 722
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 725
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 726
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 727
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 728
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 731
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 732
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 733
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 734
    Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/plugins/link-library/link-library.php:1) in .../public_html/wp-includes/pluggable.php on line 890

    I have the same problem as cinemaminima.

    And on the public Web pages:

    Fatal error: Call to undefined method wpdb::get_blog_prefix() in /home/h21203/data/www/azovsea.in.ua/wp-content/plugins/link-library/link-library.php on line 4405

    While deactivating plugin the problem is:

    Warning: Cannot modify header information – headers already sent by (output started at /home/……/wp-content/plugins/link-library/link-library.php:1) in /home/……./wp-includes/pluggable.php on line 868

    I have the same problem as bratki.

    Totally broken, i want to downgrade it!

    csigncsign

    @csigncsign

    I have this, too:

    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/25/d13574424/htdocs/multisites/wp-content/plugins/link-library/link-library.php:1) in /homepages/25/d13574424/htdocs/multisites/wp-includes/pluggable.php on line 690
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/25/d13574424/htdocs/multisites/wp-content/plugins/link-library/link-library.php:1) in /homepages/25/d13574424/htdocs/multisites/wp-includes/pluggable.php on line 691
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/25/d13574424/htdocs/multisites/wp-content/plugins/link-library/link-library.php:1) in /homepages/25/d13574424/htdocs/multisites/wp-includes/pluggable.php on line 692
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/25/d13574424/htdocs/multisites/wp-content/plugins/link-library/link-library.php:1) in /homepages/25/d13574424/htdocs/multisites/wp-includes/pluggable.php on line 890
    Kebas53

    @kebas53

    Seems to be that the file link-library.php is saved with wrong coding format. All strange characters in the file. Please upload the right file…

    Kebas53

    @kebas53

    Problem halfway solved.

    Download file link-library.php to a local disk (networkdisk) and upload it again to your webserver overwriting the old one !!

    For me the error on all other pages behalve of the link-page are gone.

    On the link page I still got an error:
    Warning: Cannot modify header information – headers already sent by (output started at /customers/domain/domain/httpd.www/wp-content/plugins/link-library/link-library.php:1) in /customers/domain/domain/httpd.www/wp-includes/pluggable.php on line 890

    Also noticed, that my JWPlayer isn’t working anymore!

    Kindly regards,
    Jacob.

    fmclaughlin

    @fmclaughlin

    I am experiencing the same problems.

    christian-s

    @christian-s

    I downloaded the 4.2.6 package, unzipped locally and uploaded the link_library via FTP to site and let it overwrite all files as needed. This did not solve the problem for me. Still getting header errors.

    deano65

    @deano65

    I updated the plugin just 30 mins ago and it has now stopped working.

    tried to re-install and no luck!

    deano65

    @deano65

    im getting:

    ‘Plugin could not be activated because it triggered a fatal error.’

    I was getting the “headers already sent” warning mentioned above, which mentioned WP Super-Cache. When I turned Super-Cache completely off, including regular WP caching, the warning went away. Obviously, only a temporary fix, but those who are receiving other errors might look into disabling caching until the author has fixed this problem.

    TheGraciousPantry

    @thegraciouspantry

    I disabled Link LIbrary completely until it’s fixed.

    Plugin Author Yannick Lefebvre

    @jackdewey

    The double-checked the changes that I made last night and the main one which might be responsible for this is the line that says:

    network: true

    towards the top of the plugin.

    Please try removing this line and see if it works for you.

    Which version of WordPress are you using?

    The odd thing is that I am not getting errors on my live site with the new update.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Link Library Version 4.2.6 problem!’ is closed to new replies.