Support » Plugin: Link Library » Link Library and Category view with excluded tags

  • Resolved Andyt8

    (@andyt8)


    Hello,

    I’m unsure, but it seems to me, I found a bug with Link Library if I use for example: [link-library-cats settings=4] and later [link-library settings=4] on the same page and exclude links with tags.

    The first problem is a wrong number of links. With [link-library-cats settings=4] I get all links (also excluded links by missing tag). Therefore I see for example 11, but it should be 2. With [link-library settings=4] it is correct. Is see only 2 links.

    The second problem is a wrong list with [link-library-cats settings=4], because some categories should be empty and should show at least 0 or be completly removed. With [link-library settings=4] it is fine. I see only categories with correct links (using css with nolinksfoundincat from support article). Therefore it show not “no link found”.

    • This topic was modified 3 months, 2 weeks ago by Andyt8.
    • This topic was modified 3 months, 2 weeks ago by Andyt8. Reason: small logical correction
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Yannick Lefebvre

    (@jackdewey)

    Hi Andy, Thanks for the feedback. I’ll work to investigate these issues when I have a moment.

    Thread Starter Andyt8

    (@andyt8)

    Thank you for your fast response. No problem, it isn’t a big problem. Take the time.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Could you test my latest code changes to address this issue? You can download the latest plugin code from my Github page: https://github.com/ylefebvre/link-library

    Just download all files as a zip and replace the plugin files on your site with these ones, then let me know if it now handles tags correctly.

    Thread Starter Andyt8

    (@andyt8)

    Hello,

    I tried the new version from Github, but it seems to me, the result isn’t correctly.

    With the new version and shortcut [link-library-cats settings=4], it show me all sub-categories and the number 0 for results. However, that isn’t correct, because two of them should show at least 1.

    It would be Ok for me if it show still empty categories, but the number should be correct.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Just pushed another test update to github. Please update once again and let me know if the results are now more representative of what you’d expect. Thanks!

    Thread Starter Andyt8

    (@andyt8)

    Thank you for the fast new test version. I did the update and it looks really good except one situation.

    With the latest version it show me the right number next to the categories. There are two link library for two pages and on one it show me links for a category (and all subcategories) execpt the first tag and on the other all links for the same category execpt the second tag. The numbers for the links in each subcategory is between 0 and 42. According to my check, that is correct.

    Categories with 0 links are still there, but don’t use html code for “Hyperlinks”. That is nice and Ok for me. However, there is one failure, if such an empty category is on the first position. It has still the html code for “Hyperlinks” (<a href=…), but use the same link like the top category.

    There are no links which use the top category. They only use subcategory. I show the top category for better overview, because it show me a nice title. Additional it is easier to extend both link libraries if there will be new links with new subcategories.

    Once the subcategory gets one or more links, the HTML code for “Hyperlinks” is correct.

    I hope the explanation was not written confusingly. Have a nice weekend 🙂 .

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    I think that I understand what you mean and have made a new update to the code on github. Please update and let me know if this works as expected now.

    Thread Starter Andyt8

    (@andyt8)

    With the latest version, it looks as expected. Thank you very much.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Awesome! Thanks for the feedback. I’ll release a new official version today with these changes. You won’t get an update right away since I had already bumped up the version in what I gave you, but next time there’s an update, these changes will be in there.

    I’ve upgraded to version 7.1.9, but I still see the empty category link with [link-library-cats settings="1"]. For example, on https://khatchad.commons.gc.cuny.edu/research/background, there are no textbook links, but there is an “empty” category https://khatchad.commons.gc.cuny.edu/research/background/#textbooks that goes nowhere. Since this category has no links under setting 1 in my case, it should not appear in the category list.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Is it possible you have the option labeled ‘Hide Results if Empty’ unchecked under the Common tab of Library Configurations?

    The other “library” ([link-library-cats settings=”2″] at https://khatchad.commons.gc.cuny.edu/teaching/csci-40500-77100-software-engineering-sp-21/#Resources-2) now looks different. There, empty categories are grayed out. I would expect them to be absent instead.

    On the contrary, under https://khatchad.commons.gc.cuny.edu/teaching/csci-40500-77100-software-engineering-sp-21/#linktable, I would expect “Tutorials” to be *present* since it has a non-empty subcategory (currently, it’s grayed out).

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.