Support » Fixing WordPress » Link function in visual editor broken

  • I posted something similar earlier, but found out the issue is not theme related. Now I’m back where I started. I’ve also already tried disabling all plugins, this does not fix the issue.

    Basically, the link button in the visual editor is malfunctioning. The window loads and displays the fields for entry, although the “link to existing…” is greyed out and not available. If if enter a url and info into the fields, I get redirected to the “posts” page and the changes never take effect.

    I see others have had a problem similar, but for them the link window doesn’t load properly at all. That is not my issue. It loads, just isn’t functional.

    Can anyone point me in the right place?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Link to your site (default theme with no plugins)?

    *I cannot disable plugins on that as it is the live production site, and it needs to stay up. I mirrored the site to my local machine (mamp) and am testing different fixes on it here.* Stupid, didn’t read your response correctly

    Can I ask what you mean about linking to the plugin disabled site? Wouldn’t that be the same as just disabling plugins on the live site? And if I disabled the theme, I would lose all of the formatting?

    It’s standard troubleshooting to try to identify (and solve) the problem – deactivating plugins, switching to the default theme, resetting the plugins folder in case one may still be causing problems. You may also want to check for javascript errors. For sure, make sure any and all caches are cleared. Try another browser just in case.

    You can’t really assume that the local site is identical…

    Oh, I see, thanks. I’ve tried disabling plugins, different browsers, etc. All null.

    The thing is, the issue is only with the visual editor, nothing on the site itself is broken. Do you happen to know which wordpress folders and files are responsible for displaying the wp-admin tools and functions?

    There were quite a few similar threads on problems with the visual editor when WP was updated to 3.5 – various themes and plugins had problems – and/or javascript-related problems. You could start there:

    You might look at this thread:

    Searching for other threads will find more discussion of the problems others had.

    Is there a reason you are not using your theme’s support?

    Today in visual editor suddenly the link/unlink command was greyed out. Could make the link with html. Discovered it is due to the latest update of nextgen gallery 2.0.0 (done today!). Deactivating it solved the problem. It seems many people have problems with that upgrade so I plan two possible actions: revert to nextgen 1.9.13 (instructions can be found at the nextgen site) – or wait for the next upgrade like 2.0.1 or something while 2.0.0 is activated again. We are told NOT to delete the plugin as not to lose all data. At least I can use the html without problems as for now. I did download already the 1.9.13 version (must be uploaded by FTP to override the latest update). At least I know for my other blogs: no upgrade!

    @bjprc – your issue is totally unrelated to this outdated thread – please post on the NGG forum if you need help or discussion on it:

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Link function in visual editor broken’ is closed to new replies.