Support » Fixing WordPress » Link Checker Error – won’t read site

  • I am attempting to run a link checker over this site and am getting a ‘no info no return’ error. I believe it is a 204 but am not positive. I tried Xenu link checker and some other systems but they won’t follow the links.

    I have a caching program and disabled it. The site was recently migrated so I know I need to check links but am not understanding the response. Any advice would be appreciated, I’ve tried looking it up but am only finding how to check links, not why I would get the response I am.

    thank you

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Have you tried the W3C Link checker?

    A status code 204 normally isn’t bad. It’s not an error, it just says: the resource was accessed successfully, but no content was returned because there is intentionally no content.

    You could also have a look at my Link Checker. It crawls a website like a normal visitor and thus also follows links.

    Best regards,
    Marco

    The problem with using a plugin is that it drains the resources on your site when, ideally, a remote link checker (local or online) can do the job.

    Another couple of free online link checkers:
    http://www.brokenlinkcheck.com/
    https://www.drlinkcheck.com/

    I’m stumped as to why Xenu is suddenly failing on WP sites. I’ve been using it for years on WP sites and it’s always been a rock solid link checker. 🙁

    My Link Checker is a remote link checker with a WordPress integration. The user interface is in the plugin, but the work is done by a crawler operated by me. Thus not a classical plugin solution, but with the comfort of a plugin 🙂

    @mbsec: My bad! I assumed it was like the other link checker plugins.

    @karyls: I’ve been running some checks and I’ve ruled out any obvious issue between Xenu and Win 10 (or it’s firewall). I’m getting a 406 error (not 204) which suggests that the problem has been created by a recent(ish) server update or a mod_security issue. Given that Xenu is pretty old, my guess is that it needs updating and I don’t see that happening any time soon.

    • This reply was modified 1 year, 4 months ago by  esmi.

    I ended up using a plug in temporarily- thank you, Marco. I have used Xenu for years bit it’s time to shelve it. I am not worried about drained resources, it’s fast and not running except briefly.

    I understand 204 isn’t particularly bad but I am concerned about how google views 204s. I haven’t been able to get an answer on that. Google has been on the site all day so I will check webmaster tools in a few days.

    thank you everyone.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Link Checker Error – won’t read site’ is closed to new replies.