Support » Fixing WordPress » Link Categories

  • I’m currently using 0.72beta2. I’ve been having a problem where WordPress doesn’t actually commit any changes I make to the Link Categories (e.g. Sort Order). I thought this might have been due to my somewhat unorthodox upgrade method, so I tried a completely new install (no upgrade) on a different site and had the same thing happen. Has anyone else seen this, or am I just missing something stupid?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi Indeboi,
    I’ve not seen that problem before, and I cannot reproduce it.
    On the link category manage page what value do you see for the categories?

    I’m not sure what you mean by the value. After a fresh install it shows the default "1 General N Y Y Y Y name N ..." listing. If I change something like sort method to ID, the same line appears after saving. I’ve tried going into the database, and I can manually change the values and they appear correctly on the web, but not from that page itself. I could e-mail you the admin password for my test site (because it doesn’t matter, and I’ll be deleting it anyway) so that you could take a look at it if that would help.
    For additional info, it’s a RedHat 9 machine running PHP 4.2.2, Apache 2.0.40, and MySQL 4.0.15 (from MySQL AB, not Red Hat). Not sure if maybe that could be the problem (I could easily go back to 3.x from the regular distribution).

    In your index.php, which function are you using to display your links? The default uses get_links(), which doesn’t honor the settings in the Link Manager screens. Try using the get_links_list() function and see if that does what you want.

    Hi Indeboi
    Do any of the link category settings save?
    I cannot understand it at all. If the default values are showing then you have the correct tables with the correct columns.
    Can you change any other data? e.g. create new link categories, create links, etc? I’m thinking could your DB connection not have update permissions (for the one table?)

    dougal – It’s not my implementation, it’s actually a problem on the Link Categories page. When I adjust the settings there, they do not save to the database.
    Mike – I can create links and adjust them like normal. I can also create new link categories with any settings I want, however once they are created I cannot change the settings without manually editting the database. And everything else works just perfectly (I really love what you guys have done, this problem just baffles me)
    Just to update you on what I’ve tried (I’ve also re-installed WordPress from scratch for each of these):

    • Downgraded to mysql 3.23.56 RPMs from Red Hat.
    • Explicitly granted all privileges to my user for that specific table.
    • Used the root user for the database connection for WP.

    I think that’s everything – I’ve used the beta version linked to on the DevBlog, do you think what’s in CVS might be better?

    Well, it’s not really a big deal right now (more of a bewilderment and inconvenience). I put my site back the way it is on the latest MySQL and everything else is running just fine. If you haven’t had a report of this from anyone else, it might just be something screwy with my box and I’ll investigate it more later (perhaps when 0.72 comes out officially). If you do find anyone else with this problem and want to troubleshoot it, I’d be more than willing to set up an account on my server for you to take a look at an install on it. For now, keep up the good work.

    I’m also getting this same problem. I try to adjust category properties in the admin interface but nothing is changed on the database.

    Hi, I recently tried using IE instead of Mozilla firebird to edit my link categories and viola! it worked. must be something wierd in the firebird coding…
    ie it is…
    that’s a real inconvenience…

    Funky. Works fine for me with Mozilla 1.5.

    I think I’ve found this.
    If you have register_globals set to off in your PHP installation, the link category manager exhibits exactly the symptoms originally described. Category settigns not saved.
    I’ve now committed a fix to this in CVS. It will be included in the next release.
    diff -r1.9 linkcategories.php
    > $submit=$HTTP_POST_VARS[“submit”];

    Hey, cool. I forgot all about this until recently. I just changed register_globals to On, restarted Apache and it’s working now! Thanks Mike! As far as the change you committed, does that mean that the next release will no longer require register_globals to be On for this to work? Not a big deal, just want to know if I can turn it back Off once .72 is released. Once again, thanks and keep up the good work!

    Just answered my own question. Installed .72 gold, turned register_globals Off, restarted Apahce, and… it works!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Link Categories’ is closed to new replies.