WordPress.org

Support

Support » How-To and Troubleshooting » Link Catagories Not showing

Link Catagories Not showing

  • hi all,
    I just reinstalled wordpress 1.5 from not having ablog in a few months, installation went well, and theme search went well, even my custom editing of the theme went well.

    I have pretty much everythign thing done but cant get the link catagories to show, instead itshows all links mixed together. Im using Rin theme with a new install of 1.5 so is it somethign in teh the theme or the whole package?

    if so any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Add this code where you need it in the sidebar.php

    <ul>
    <?php
    $link_cats = $wpdb->get_results("SELECT cat_id, cat_name FROM $wpdb->linkcategories");
    foreach ($link_cats as $link_cat) {
    ?>
    <li id="linkcat-<?php echo $link_cat->cat_id; ?>"><h2><?php echo $link_cat->cat_name; ?></h2>
    <ul>
    <?php wp_get_links($link_cat->cat_id); ?>
    </ul>
    </li>
    <?php } ?>
    </ul>

    As it happens my blog in also using RIN, you can see how this code looks Cranial Cavity

    EDIT: I should have also said delete this code from the RIN sidebar.php and replace it with the above code:

    <li><h2><?php _e('Links'); ?></h2>
    <ul>
    <?php get_links('-1', '<li>', '</li>', '<br />'); ?>
    </ul>
    </li>

    seems to have worked but now the title for Lnks is gone.

    so I added this back

  • <h2><?php _e(‘Links’); ?></h2>

BTW, have you looked at your site in FireFox?

I suggest a quick peek, it is a complete disaster (no offense intended).

All the content is pushed to the right side so far the left side of the screen is nothing but white background. Not sure but it may be caused by how you edited the nav bar at the top, or possibly because you have tried to incorporate shockwave into the site.

Regardless, it needs some serious tweeking, fast!

figures shockwave kills everything

I am having a similar problem with the benevolence theme. I tried this fix, and it didn’t fix it, so I put it back.

I have the default catagory showing up, but none of the others.

you can see it at http://www.notbecky.net

Any ideas would be appreciated.

I would like to echo NotBecky’s comment above, with one small change. It actually did break it down into my category settings (sort of) but the size/font settings got all jacked up.

Please see this for an example.

Any ideas on how to fix that?

Thanks!

lickmysticks
Member

@lickmysticks

I’m having the same problem. I’ve got three catagories and all the links jumbled under the default. I am so confused!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Link Catagories Not showing’ is closed to new replies.