Support » Plugin: Amazon Associates Link Builder » Link Builder credentials won’t save

  • Resolved shazzaaxo

    (@shazzaaxo)


    I am registered as an Amazon affiliate in several countries.
    I installed the Associates link builder plugin to my WordPress site. When I go to the settings tab to enter my details, the “save changes” button does not work.
    When I enter the different marketplaces, firstly there is no option to choose my default marketplace from the list. All of them are shown as a default marketplace beside my tracking ID.
    After entering all my API key and credentials the “save changes” option is still blanked out.
    I do not use an Adblocker on my computer.
    Why is there no option to save everything I have entered and why do I not have the option to select my default marketplace?

    • This topic was modified 2 years, 7 months ago by shazzaaxo.
    • This topic was modified 2 years, 7 months ago by shazzaaxo.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same here – cannot save changes

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @shazzaaxo & @matthew2582,

    The issue that on first time entering tracking-ids, all marketplaces are marked as default marketplace is known bug and we will fix this in next release. On saving the settings the first marketplace will become the default and later you can make any row as default marketplace.

    For the issue of not able to save settings:

    • Have you checked the Conditions of Use checkbox just above Save Settings button?
    • Are you on the latest plugin version?

    If you are following above and still facing the issue, please provide the following details to help us to debug the issue:

    1. Browser version on which you are facing the issue.
    2. Does the issue occur on all browsers or only a specific browser?
    3. PHP version (You can use plugins like display PHP version that display your PHP version on the WordPress dashboard)
    4. WordPress version
    5. PHP error logs
    6. Operating System version(OS version).
    7. Browser console log error (if any) generated at the time of the error. Steps to get the console logs:

    • Open the Console window in Chrome using Ctrl + Shift + J (or Cmd + Opt + J on Mac) Follow this for reference.
    • Hit the Save button and check the console log errors
    • Send us the screenshot of console log as it is by sharing them using any 3rd party image sharing tool.

    8. Screenshot of your settings page with grayed out Save button. Please replace your store-ids and credentials with dummy values in screenshot

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @shazzaaxo & @matthew2582,

    Since we didn’t get any response from you, we hope that your problem is resolved. Please feel free to reopen the thread with details asked in the last comment in case of the issue still persists.

    Check your Adblocker if it does not work!

    Since no one else replied…
    Browser: Firefox Developer 65.0b8
    PHP: 7.0.33
    Wordpress: 5.0.2
    no error in log
    OS: Win 10
    Console error: Loading failed for the <script> with source “https://hiddenurl.net/wp-content/plugins/amazon-associates-link-builder/js/aalb_credentials.js?ver=1.8.0”.

    Can’t upload a screenshot through this interface. But I can guarantee you — it’s grayed out. And yes, I turned adblocker off.

    skunkgrunt

    (@skunkgrunt)

    Well, turning adblocker off worked for me. Turned it off for the entire domain, then refreshed the page. Worked.

    Thanks. Ad Blockder was the problem also for me.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Link Builder credentials won’t save’ is closed to new replies.