• In previous versions of WordPress, whenever I clicked a link in the Gutenberg editor, I could rapidly see the “open in new tab” and “set to nofollow” options. With the new WordPress 6.3 update, that’s no longer possible. Now, I have to click the link, click on “Edit”, and then click again on “Advanced Features”. No more a seamless experience, now taking more time to select a simple option. I would love if you could revert this in your next update.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You’re welcome to contribute to the issue here:

    https://github.com/WordPress/gutenberg/issues/52216

    and you can test some new functional behaviour here:

    https://github.com/WordPress/gutenberg/pull/52799

    @vascolou that’s very true. I thought I was the only person bothered by this. It’s not too big a deal, but now I need 5 clicks where previously I needed about 2 if I am not mistaken. That adds up for people who, like me, spent their lives working in WordPress. In fact, by default, all links should open in new tabs. It wouldn’t make sense close your own page as people click on a link that’s on it. It’s better to have people directed into a new tab.

    Since I am here and seeing I love complaining, there was also an “i” at the top of the page in previous versions of WordPress. That has since been hidden but it was one of the most useful features for showing the header structure of a web page. That’s something that’s important (or not) for SEO. Anyway, let me get over to github as suggested by the other poster

    Thread Starter Vasco Lourenço

    (@vascolou)

    “In fact, by default, all links should open in new tabs.”

    Yes, WordPress could at least differentiate internal from external links, making only the latter open in a new tab.

    whistlerdan

    (@whistlerdan)

    I agree that this is a huge step backward. It’s one thing to hide it behind the dropdown for advanced options, but the fact that you can’t even get access to the advanced options until you have first added the link and then chosen to edit the link is maddening. Surely the point of hiding the options behind the advanced option was to tidy things up. Why tidy it up twice?

    I got a worse bug. Some links allow me to edit their advanced options, and some don’t. I thought it is related to context: if the link is placed inside a paragraph, it won’t have, and if inside a list, it will, but I can’t find any pattern. It’s completely random.

    • This reply was modified 8 months, 4 weeks ago by neoswf.
    • This reply was modified 8 months, 4 weeks ago by neoswf.

    I just tested this using the Gutenberg Plugin (Version 16.5.1) and the “Open in new tab” check is right there. This is what I see:

    @neoswf, I was not able to reproduce what you desacribe. Could you please open a separate support thread for your issue?

    • This reply was modified 8 months, 4 weeks ago by Alvaro Gómez.

    On a desktop or a laptop, right? This does work on my laptop but not on either my tablet (Samsung Tab A) or phone (Pixel 6), using multiple browsers.

    Here’s what I see on my tablet, no new tab option:

    https://pasteboard.co/LRnQZ7B538x3.jpg

    I’ve discovered a workaround for now.

    I’ve installed the plug-in “Open External Links in a New Window” and that fixes my issue for now. This is not the only similar plug-in available, but it’s simple and doesn’t bug me to upgrade to a Pro version.

    I think where we were getting our signals mixed was that the advanced area does not appear when you are inputting the link URL before hitting enter. After the link is entered and you click on the linked text, you would then get the slider to set it to open in a new tab.

    Sorry for the confusion and thank you for following up, Alvaro. I appreciate the effort to help me. Have a good weekend.

    It’s a pity that we now need another plugin for a simple thing such as getting links to open in a new tab. Such a simple thing yet for some reason, the contributors-that-be will not acquiesce to input from actual users.

    On a desktop or a laptop, right? This does work on my laptop but not on either my tablet (Samsung Tab A) or phone (Pixel 6), using multiple browsers.

    There should be no differences between laptop or table, @mocha24

    Have you tried clicking on the link once you paste the URL? The checkbox should show then.

    There should be no differences between laptop or table, @mocha24

    Have you tried clicking on the link once you paste the URL? The checkbox should show then.

    It does show up then, but it should be available as an option during the link’s creation (like it always was before version 6.3.x

    But the plugin works for me, so okay for now.

    The developers should really listen to users’ feedback on this one and put the slide back in.

    I agree that there are too many clicks to get to the link advanced options. What happened? It was really helpful to have the “open in new tab” checkbox show up automatically when you create a link. This is a lot of extra work for me as I enter site content.

    tylerbenedict

    (@tylerbenedict)

    This multi-step process to simply check the “open in new tab” box is horrible and a serious time waster for avid users. I have to go through these extra five clicks approximately 50 times per day now, which is massively inefficient.

    Additionally, training new users on WP and how we do things (which is to open external links in a new tab) adds more complexity to what should be an extremely easy, straightforward option.

    PLEASE, PLEASE, PLEASE go back to showing advanced link options in the same window where we add the link without any extra steps, clicks, or processes. PLEASE!!!

    Thanks.

    Adding my voice to the call to fix this. It’s utterly absurd that there’s a link option I cannot set when creating a link, and as tapiwaz says when you’re doing this all day, the difference between two clicks and five really adds up.

    Having the “Open in new tab” missing from the UI when creating a new link is problematic and is a poor UI design choice. This is an option that should be present when a link is created and when a link is edited. Please change the UI back to what it was before when the “Open in new tab” was present in the new link creation context.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Link Advanced Options’ is closed to new replies.