Support » Plugin: TinyMCE Advanced » Line Breaks Instead of Paragraphs

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    WordPress Dev

    In WordPress there is a feature called wpautop. It is on by default and replaces <p> with two line breaks when saving, then puts the <p> back when displaying the posts on the front-end.

    In TinyMCE Advanced this can be turned off. Then the <p> and <br> are not removed on saving and you can see them in the Text editor. There are other plugins and “hacks” that do something similar, and it sounds like you had one of these hacks that got removed when WP or your theme was updated.

    You can enable this in TinyMCE Advanced, then re-edit any affected posts and add the paragraphs (from the Visual editor). Or you can disable it in TinyMCE Advanced and in any other plugins and/or hacks you may have added, and use the default behavior (line breaks instead of <p>).

    Thanks for your time, Andrew
    The problem is that when I went through this with moderator TP over at Support (see the link above) I already tested with the TinyMCE <p> Advanced feature both turned on and turned off.
    Also tried with the Black Studio TinyMCE widget on and off as well
    Neither made any difference
    I’m not aware of any other hacks or plugins that offer the same feature, so the odds are I don’t have anything else running
    For now I’ve just been hitting return twice for every paragraph – once published it seems to format ok
    Cheers mate

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Line Breaks Instead of Paragraphs’ is closed to new replies.