Support » Fixing WordPress » Line breaks are driving me effing NUTS!

  • I’ve read forum posts about this issue going three years back! I’m shocked that wp can’t fix this issue!!!

    <br clear="all" /> does not work

    <style> table br {line-height:0pt}</style> does not work

    I made a white line 1 px x 400 px and inserted that … Not only does Wp make it smaller, it puts the lovely gray frame around it…. ARGH.

    The only thing I can find is to change the CSS. But for the life of me (I’ve never done this and my few forays into playing with CSS it never did what I told it to!) I can’t figure out what file!????

    I cannot find a stylesheet in my files anywhere. I’m usuing Atahualpa (aka hoopaloopa because I can actually pronounce that!)

Viewing 15 replies - 1 through 15 (of 15 total)
  • This is what I’m trying to do:

    In your CSS you have no top or bottom margin on your paragraphs – that is your problem

    in your stylesheet, line 73 style.css change the margin on the p tag to this:

    p {
    margin:10px 0;

    I just can’t figure out WHERE

    please help!!

    I don’t understand what you’re trying to do.

    First: do you have a file named style.css included in your theme or any file that ends with .css?

    Not that I can find… but I was looking for something called “stylesheet.css” But I didn’t run across that in any folder but.. there are tons of places to look…

    Any hints as to where to begin?? wp?? themes??? content?

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Try looking at wp-content/themes/atahualpa/style.css and add your CSS to the end of that short file.

    Don’t forget to save an unmodified copy of that file in case something goes horribly wrong.

    I found a css folder… but nothing in there is named style or stylesheet.

    Sorry Jdembowski…missed your post. Found that and trying the fix.

    found it… still can’t have line breaks! This the most annoying part of word press. Line breaks!!! REALLY??? Good grief!

    If I had know such an annoying thing would cause me to lose days of progrmming… I would’ve stayed on blogger!

    tried this too… didn’t work

    1) turn off the rich text editor in user profile
    2) edit file: (base) wp-includes/formatting.php

    after line 62 which has:function wpautop($pee, $br = 1) {
    add this: return $pee;

    And wpautop will not mess with your html tags much … it does still convert
    to < br /> and it performs the php html_encode (or htmlidentities) function to special characters, like quotes.

    Anyone know how to add line breaks PLEASE HELP ME!!!!!

    SORRY, File above was in wp-includes/formatting.php


    After much more hair pulling – I’m just documenting here in case someone else is going nuts!

    I found a forum that suggested using <code><br /></code>

    This seems unstable. It works but when you go back into the WYSIWYG, the br bits disappear but WP seems to act as if they are…. but I don’t trust what I can’t see!

    For the record, I also tried typing a period and making it white (bg color) but the gaps are huge.

    The best thing I’ve found is
    <style> table br {line-height:0pt}</style>

    Which gives me the same as a shift return OR

    <div style="height:1.4em;visibility:hidden;">1</div>

    This is the equivalent of 2 lines visually.

    I hope this saves someone from the headache I’ve had!


    If you just want a hard line feed:

    ‘<br class=”blank” />’

    Saildude… doesn’t it get deleted???

    For some reason no it does not get deleted. I use it on my site regularly to help formatting. Seems to be OK even when I switch between HTML and Visual editing.

    So far, it doesn’t seem to get deleted! What amazing is I read forum posts three years back and never found that!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Line breaks are driving me effing NUTS!’ is closed to new replies.