Support » Fixing WordPress » Line break above DOC declaration a problem?

  • I am concerned.

    If you go to and view source you will see I have a line break above the DOC declaration.

    Somewhere else I read that it has to do most likely with a white space above a file (either header, main template or plug-in)

    Well I was more thorough than that. I looked at everything LOL.

    2 had line breaks above them and 3 below the ending tag. Of course I cleared that up.

    However I see NO change. Not sure if this has something to do with the reason my BLUE sidebar on the LEFT is also extending above the navigation area or not. You’ll see on the RIGHT sidebar it is not. The right side bar is the way it should appear, by default.

    Perhaps if I corrected THAT it would fix the problem. I know I am grasping at straws but feel its important to correct since it appears this makes it more difficult for search engines to find you.

    If anyone can look at my source code and advise, I would appreciate it.

    Having one of those pull your hair out moments!

Viewing 12 replies - 1 through 12 (of 12 total)
  • That is a bummer, and I would love to hear if you figure out how to fix it.

    I suggest setting up a clean testing environment and re-initiate your theme and plugins until you see the issue introduced.

    Gosh I’d be sort of afraid to mess it up even further doing that…

    Can anyone else look at my code to see if there is something obvious?

    spabizgal, that is why you do it in a testing environment and import your database. Working directly on your live blog is scary 😉

    Here’s the thing. I had someone else install this and so for me I am not sure I could emulate it the way it should be to preview this. That person is no longer available. That is why I was hoping someone could help me here. ;0(

    I am quite php NON savvy.

    Can someone take a look at my source code to see if there is something present that might be doing this, that I am not seeing?

    These are the only plugins I have activated.
    Tried removing all and no difference.

    WordPress Database Backup
    Add Meta-Tags

    I have one in there for Adsense but have it disabled.

    Here is something else that might give a clue.

    When I view the source code on each individual post, the doc type is where it should be, right up to the top with NO space above it.


    However if I select that same post, from RECENT POSTS area, and THEN view the source, I do get the blank area above the doc type when I view source.

    Any insight? I am concerned this line break issue might be responsible for my page load issues.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    I would love to look at your source, but your page just sits there, never finishing loading. Whatever you’re doing is taking a loooooooong time to finish.

    Can you try again Otto? YIKES…I was in there changing something, sorry.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Still no joy, I can’t access the page at all. It just sits there spinning its wheels.


    That is odd because I can pull it right up?

    Are you on a cable modem or DSL?

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Well, actually, at work I believe I was on an OC-12, but that’s rather beside the point. It appears to be working now. 🙂

    I’m seeing the blank line on your home page and on Pages, but not on individual posts. So I’d look for code in your theme or in plugins that calls “is_home” or “is_page” or perhaps “is_single” and see if there’s something in there that’s inserting a blank line. I would suggest checking your theme’s functions.php first and then looking in the plugins. It’s unlikely to be in the other theme files, but it’s possible.

    Unfortunately, it could be anywhere. The most common is a blank at the top/bottom of files, but it’s entirely doable to accidentally create it anywhere.

    Hi Otto42…thanks for the suggestion
    So you see anything here that stands out in my functions?

    There was not a break above or below the script in there but as you can see some wide gaps elsewhere

    Would this cause the problem? (before I go changing it)

    [long code moderated – use]

    Its odd because posting it above I don’t see the extra lines above the ?> at the bottom…..there were about 4 but I have not changed it YET

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Line break above DOC declaration a problem?’ is closed to new replies.