[resolved] line 16 - undefined function is_network_admin (5 posts)

  1. Arrow2c
    Posted 5 years ago #

    I tried the upgrade utility for version 3.0.1 to 3.1 by ftp.

    I am able to access forum, only not the admin section.

    This is message after I uploaded 3.1 ftp, through the wordpress admin upgrade section;
    Downloading update from http://wordpress.org/wordpress-3.1.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Installing the latest version…

    Could not copy file.: /wp-admin/css/theme-editor.dev.css

    Installation Failed

    Now this is message after I tried to access admin panel in WP ;

    Fatal error: Call to undefined function is_network_admin() in /home/fbecjbnn/public_html/urtopics/wp-admin/admin-header.php on line 16

    TY in Advance

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    You have to 2 separate issues:

    Fatal error: Call to undefined function is_network_admin() ...

    indicates that your upgrade did not complete successfully because of:

    Could not copy file.: /wp-admin/css/theme-editor.dev.css

    - switching to the Twenty Ten theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to try logging into your site to get this to kick in fully.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress using FTP.

    - re-running the upgrade manually using wp-admin/upgrade.php.

  3. Arrow2c
    Posted 5 years ago #

    The last suggestion worked.

    Download Full install file for version 3.1

    Opened FTP, copied wp-config file from version 3.0.1 to overwrite wp-config in version 3.1

    Deleted ALL folders and files EXCEPT the wp-content folder as instructed on the old version 3.0.1

    Then copied all folders and file from the new version 3.1 (except the wp-content folder), by FTP to host.

    Signed into wordpress, and as instructed, clicked upgrade button, and wordpress works great to this point.

    Thankyou esmi for the great advice and instructions.

  4. Calin
    Posted 5 years ago #


    I have the same problem. I re-installed my wordpress hoping that it will work but nothing. I still get the error. Any suggestions?


  5. Calin
    Posted 5 years ago #

    By the way, I reinstalled 3.1

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.