Support » Plugin: WooCommerce » Limiting shipping does not work anymore. Is it a bug?

  • Using WooCommerce v. 2.6.13

    I have a shipping class (flowers) for products that we only ship to certain zip-codes.

    This worked fine before. When a client tried to order flowers to another part of the country, WooCommerce said: “There are no shipping methods available.”

    That is exactly what I want and it worked before.

    After update, the limitation just isn’t there anymore.

    People can order flowers to any address at no cost.

    Is this a bug?

    I have tried changing settings, saving and changing back, but problem remains. I can not get WooCommerce to say “There are no shipping methods available.” anymore.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support RK

    (@riaanknoetze)

    What version did you update from? If it was pre-2.6 then you’d need to make sure your shipping zones are set up correctly.

    Also, how is your shipping methods configured – are you using shipping class costs with the Flat Rate shipping or another shipping method (powered by a 3rd party plugin) altogether?

    Atm, there’s too little information to troubleshoot this 🙂

    Updated from previous version – always keeping my plugins up to date.

    No other plugins that affect shipping.

    This is the shipping method that applies to the zip code range where we do ship flowers:
    Shipping method

    This is the shipping zone “Rest of the world” which is there because we sell other stuff than flowers to all of the country:
    Rest of the world

    “Blommor” is the shipping class for flowers. Here I have left it empty, which should mean the shop should echo: “There are no shipping methods available.”

    If I put a sum in that field, it shows up in the shop. So everything seems correct set up to me. I’ve also switched on the error tracking mode for shipping, and it also shows that the correct shipping zones and classes apply.

    But I just don’t get the “There are no shipping methods available” message to show up.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Limiting shipping does not work anymore. Is it a bug?’ is closed to new replies.