Support » Plugin: WooCommerce » Limit number of posts

  • Resolved El Pablo

    (@el-pablo)


    I’m currently developing a new website, based on Storefront. On my home page, I have the following 3 product loop sections: ‘new products’, ‘featured products’ and ‘popular products’. I disabled the other standard ones.

    We are filling the webshop with products now and I noticed that there isn’t any limitation in the number of products in these product loops. Each newly entered article is just added, my section ‘new products’ already counts 24 items. Same for my section ‘popular items’. (https://prnt.sc/s9bice)

    How can I limit the number of items, like 8 for example? Is there a known filter to do that?

    Please note, I did not use a shortcode, since these product loops are standard on the Storefront home page.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi, @el-pablo

    Can you tell me how are you doing this loops?

    Are you using Bocks?

    Regards.

    El Pablo

    (@el-pablo)

    Hi Oscar,

    I’m not doing anything. These loops come built in with Storefront. On de default Storefront home page, all these loops are standard (Popular products, featured products, …). All I did was enabled some of them, since I don’t need them all.

    Regards.

    Hi @el-pablo

    I have installed Storefront for test and I think that you refer to differents blocks that are installed on Storefront by default.

    Please, can you send an image with this homepage editing and with the right section, please?

    this is that I can see on my storefront homepage edit:

    https://ibb.co/TMcsrq5

    Tell me about this, please…

    El Pablo

    (@el-pablo)

    Hi Oscar,

    my home page looks like this: https://prnt.sc/scdtba

    As you can see, I’m using Beaver Builder for the layout, but it’s only for the first section (https://prnt.sc/scdu81). The product loops are kind of ‘auto generated’ by the theme.

    In my functions.php file, I removed a couple of the standard product loops and also changed the title om some (https://prnt.sc/scdv3k), but I suppose that has nothing to do with that.

    Hi, @el-pablo

    I that Beaver Builder is blocking the WordPress editor.

    Normally, is you don’t have any visual editor installed, you change the blocks behaviour from the WordPress editor on each block.

    If you can’t do this now, you can deactivate the Beaver Builder plugin to test this. Deactivate and go to edit the homepage. Review an change the behaviour of the blocks you want and then, activate Beaver Builder.

    Tell me about this.

    Regards.

    El Pablo

    (@el-pablo)

    Hi Oscar,

    I have disabled the Beaver Builder, but no WooCommerce block on my home page…
    https://prnt.sc/scfdr4

    Hi @oabadfol , I found the issue. I had the plugin ‘Grid/List View for WooCommerce’ installed, which messes up all the settings. Once I disabled it, everything works again properly.

    Yeah!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.