Support » Plugin: footnotes » likely incompatible with “jQuery Updater” plugin

  • Resolved Philip Faster

    (@philipfaster)


    The plugin might be incompatible with jQuery Updater plugins, it means (maybe) footnotes has a conflict with the newer version of jQuery (v3). JU only update the jquery for the front-end pages.

    Impact: Only in front end, the tooltip in the published post is not shown

    here’s the browsers’ console message:

    
    JQMIGRATE: Migrate is installed, version 3.0.0 
    (.../wp-content/plugins/jquery-updater/js/ jquery-migrate-3.0.0.min.js:2:454)
    
    TypeError: a.browser is undefined 
    (.../wp-content/plugins/footnotes/js/jquery.tools.min.js:242:10)
    
    TypeError: jQuery(...).tooltip is not a function 
    (on the post where [ref] located)
    

    but when i disable the jQuery Updater plugins, it’s working correctly

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Lol Zimmerli

    (@lolzim)

    Hi,

    The latest version of jQuery Updater plugin is a few days old; if you update it, is it still the same ?

    Best regards

    Thread Starter Philip Faster

    (@philipfaster)

    Hi,

    yes, it still the same, with very same error messages in the browser console.
    only the tooltip in the front end is not shown.

    Maybe you have to try it in your WordPress installation, see if you have the same problem.

    Plugin Author Lol Zimmerli

    (@lolzim)

    Hello,

    OK, I can reproduce that; I’ll search for a fix.

    Thank you!

    Plugin Author Lol Zimmerli

    (@lolzim)

    Hi,

    In the JQuery Update plugin FAQ:

    Q: Do I need this plugin if I’m running the latest version of WordPress on my site?
    A: No

    (ref: https://fr.wordpress.org/plugins/jquery-updater/ )

    Why did you installed it? Do you have an old WP version or is there another reason ?

    I also tested with “jQuery Manager for WordPress” plugin instead, but it does not work either.

    BTW, our ‘local’ JQuery, that comes with footnotes plugin, is fairly old. We should make use of WP built-in JQuery version. But it will takes time to change and test.

    Best regards

    Thread Starter Philip Faster

    (@philipfaster)

    Hi,

    Why did you installed it? Do you have an old WP version or is there another reason ?

    My WordPress is updated.
    But, sometimes, I need to develop and test something to improve my website. Because till now, I think WordPress still using the old JQuery to maintain backward compatibility.

    If there is no development or test in progress, then the Jquery Updater plugin is deactivated (in fact until today).

    So, actually I just found an issue when enabling both JU & Footnotes. That tooltip is just a “bonus” feature to me, so I didn’t really care.

    But, I don’t know whether this issue will affect many users using JU or similar.

    Best regards,

    Plugin Author Lol Zimmerli

    (@lolzim)

    Hi,

    sadly, I have to close this one, as it should concern too few setups, I think, and we have no time enough to deal with it.

    I appreciate your report anyway, and we will try to keep that in mind for future devs of the plugin.

    Best regards

    Hello – Footnotes Team,

    I had used the Footnotes plugin on my page: https://www.jobkhoje.com/hp-board-10th-result/. But, Tooltip Hover Not Showing properly. Errors are coming.

    “Uncaught TypeError: jQuery(…).tooltip is not a function
    at (index):300″

    Can you open this page and search this line ” Roll number from the official web portal at http://www.hpbose.org/((Footnotes)).” where I have used Footnote.

    Help me out!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘likely incompatible with “jQuery Updater” plugin’ is closed to new replies.