Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Like button visible, but does not work

  • Resolved Keirwatson

    (@keirwatson)


    A family member pointed out that the like button on my blog is not working. They assumed the problem was them, but I can see in the logs that I have not received any likes on my blog since August 2020.

    When they click on the Like button, it opens a WordPress popup for them to log in, but after completing this there is no “like” registered.

    I have tried deactivating plugins (e.g. SG Optimiser) and have cleared caches (Cloudflare and Siteground); I have renewed the Jetpack connection and used the debugger which shows no issues. Still Likes do not register.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter Keirwatson

    (@keirwatson)

    I’ve just realised another issue (probably related) which is that the related posts are no longer related to the post they appear below: They are always just the three most recent posts.

    Plugin Contributor Jen H.

    (@jenhooks)

    Hi @keirwatson,

    Regarding the Likes button issue, this is typically because of a JavaScript error. These errors are usually caused by a badly coded plugin, or something is loading an old or duplicate jQuery.js file. Deactivation of the bad plugin or removal of the duplicate jQuery.js file should fix the problem.

    As a first line of troubleshooting, can you temporarily deactivate your other plugins, and see if the problem resolves? If that doesn’t turn anything up, check for duplicate jQuery.js elements in your theme. Your theme’s support team may be able to give you a hand with that one.

    If neither of those things do the trick, you may need to flush your server cache. Don’t hesitate to ask your host for help if you need it!

    Regarding the Related Posts, I’m not seeing the same thing you are. On this post, I see these Related Posts. On this post, I see different Related Posts. I see different Related Posts still, on this post.

    Does this help?

    • This reply was modified 7 months, 2 weeks ago by Jen H..
    Thread Starter Keirwatson

    (@keirwatson)

    You are right about the related posts. They are fine. Not sure what I was seeing before!

    Re: likes, I have deactivated all of my plugins (except Jetpack and Akismet) and the like button still does not work.

    As before, when clicked on, WordPress.com is visited momentarily, but nothing then happens.

    What can I try next? It used to work 🙁

    (Likes do work, BTW, when they are clicked from within the Reader on WordPress.com)

    Plugin Contributor Stef

    (@erania-pinnera)

    Hi @keirwatson,

    I’ve just liked the post you linked in your first reply. I had no problems at all! I’m using Chrome v88.0.4324.146 on macOS 11.2

    Have you tried the Like button by using a different web browser, or an incognito window? Can you try temporarily deactivate all your browser extensions and check if the problem gets fixes that way? If it works, then reactivate each extension one-by-one to find out which one is causing problems.

    Also, can you tell me if the WordPress.com login you made before testing the Like button has been done by using the Google or Apple buttons?

    This is what I mean: https://cloudup.com/c8qyGALJC2H

    Thread Starter Keirwatson

    (@keirwatson)

    I have solved it. It’s a browser issue: Safari.

    By default Safari has “Prevent cross browser tracking” checked in preferences and this stops the like button working.

    THat’s good and bad news. Bad, because it means the lack of likes since August is mostly lack of engagement, which is odd as I have had a huge increase in visits.

    I wonder if it is possible to alert users to this with a pop up if they have this option switched on? or even a pop up with an “allow cross site tracking once” option?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Like button visible, but does not work’ is closed to new replies.