WordPress.org

Support

Support » Plugins and Hacks » Like Button Perpetually "Loading"

Like Button Perpetually "Loading"

  • crackedjar
    Member

    @crackedjar

    I posted this under a different topic, but this is more accurate. When on the media attachment page, the like button says “Loading” but never loads. On the carousel view, I have comment link but not like. The like button works everywhere else.

    Here’s what I have tried.

    Switched to different themes, such as Twenty Twelve, Twenty Eleven & Twenty Thirteen.

    Disabled all plug-ins.

    Changed sharing settings from “on for all posts” to “turned on per post,” and back again.

    Using standard post format and gallery post format.

    Switched from having the image linking to attachment page or to media file.

    I’ve tried each of these things alone and in various combinations, and I cant figure it out. It’s driving me crazy because I’ve waited a long time to be able to have the like button and now that it’s available, I can’t get it to work for me! So frustrating!

    I also tried looking at “inspect element” and got this…

    When on carousel view –

    ‘<div class=”jetpack-likes-widget-wrapper slim-likes-widget jetpack-likes-widget-loaded” id=”like-post-wrapper-22410426-23122″ data-src=”http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&slim=1&origin=http://thisthingcalledmylife.com” data-name=”like-post-frame-22410426-23122″ data-attachment-id=”23122″ style=”display: none; vertical-align: middle;”><div class=”post-likes-widget-placeholder”></div><iframe class=”post-likes-widget jetpack-likes-widget jetpack-resizeable” name=”like-post-frame-22410426-23122″ height=”22px” width=”68px” frameborder=”0″ scrolling=”no” src=”http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&slim=1&origin=http://thisthingcalledmylife.com” style=””></iframe></div>’

    When on attachment page view –

    ‘<div class=”sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-loaded” id=”like-post-wrapper-22410426-23122-51893bba85b95″ data-src=”http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&origin=http://thisthingcalledmylife.com&obj_id=22410426-23122-51893bba85b95″ data-name=”like-post-frame-22410426-23122-51893bba85b95″><h3 class=”sd-title”>Like this:</h3><div class=”post-likes-widget-placeholder” style=”height:55px”><span class=”button”><span>Like</span></span> <span class=”loading”>Loading…</span></div><iframe class=”post-likes-widget jetpack-likes-widget” name=”like-post-frame-22410426-23122-51893bba85b95″ height=”55px” width=”100%” frameborder=”0″ src=”http://widgets.wp.com/likes/#blog_id=22410426&post_id=23122&origin=http://thisthingcalledmylife.com&obj_id=22410426-23122-51893bba85b95″ style=””></iframe><span class=”sd-text-color”></span></div>’

    Maybe someone will know what this means and can tell me if there is something wrong there.

    Thanks!

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 18 total)
  • crackedjar
    Member

    @crackedjar

    UPDATE: Like button loads on posts and pages for my readers and me. On images, some users get the “Loading…” in gray, and others can see and use the button. Once someone has “liked” the image, I can see & use the button myself. If I activate carousel, nobody can like the images (the link doesn’t show).

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi! Can you send me a link to an image in the carousel that has this issue? Thanks.

    crackedjar
    Member

    @crackedjar

    Hi Richard,

    I have a private blog, but I could send you a username/password and the link if you want. Please email me at amsheppard1 at gmail dot com. Thanks. 🙂

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    That might be the source of the issue. Sites need to be publically accesible for Jetpack to function properly, but I can still take a look to see if it’s something that can be fixed. You can email the login info to support@jetpack.me

    crackedjar
    Member

    @crackedjar

    Thanks, I’ve sent an email.

    crackedjar
    Member

    @crackedjar

    Oh, I might add that my site at wordpress.com is a private site, too, but the like button is working there, on newly uploaded test pictures, but not on pictures imported from my wordpress.org site.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi,

    Yeah, self-hosted sites and WordPress.com are a bit different in how things work; self-hosted sites definitely need to be publicly-accessible for Jetpack to function, otherwise it has no way of properly connecting to your site, whereas WordPress.com sites are, well, hosted by WordPress.com! 🙂 Thanks for sending an email; I’ll try to get to it today.

    crackedjar
    Member

    @crackedjar

    Thanks.

    crackedjar
    Member

    @crackedjar

    Any news on this? I would switch to wordpress.com, but my hosting is paid up for 6 more months, and I’d have to pay more money to get the same features on wordpress.com (no ads, custom design, more space when I need it).

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    Hi! Did nobody get to your email? I don’t recall if I did it or not. If someone did reply to your email, can you reply to them again and ask for an update?

    crackedjar
    Member

    @crackedjar

    The last I heard was your post above from a week ago. I thought you had gotten the email, but just been busy.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    I’m sorry but we must not have gotten your email or we would definitely have gotten to it by now. Can you try sending it again? Try doing it through our form here instead: http://jetpack.me/contact-support/ Remember to include a link to this thread as well.

    crackedjar
    Member

    @crackedjar

    O.K. I did it. Thanks, Richard.

    Plugin Contributor Richard Archambault
    Happiness Engineer

    @richardmtl

    I see it now, and I’ll get right on it. Thanks!

    crackedjar
    Member

    @crackedjar

    Great, I appreciate it!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Like Button Perpetually "Loading"’ is closed to new replies.