Support » Plugin: WordPress RSS Feed Retriever » Like a finely tuned race car

  • thanks for your cool plugin

    I’m tempted to mark this as not a support topic, because I think it is impossible to troubleshoot

    something is hinky with caching or…?

    i’ve got a directory custom post type that I’m displaying RSS feeds on… it works… then it stops working… sometimes it comes back after clearing caches and updating the post, sometimes not

    says something about check the shortcode (I can’t remember, sorry)

    I tested on a standard post and it works without a problem

    I reverted to 1.43 and works fine

    [wp_rss_retriever url=”https://website.com/feed/” items=”9″ excerpt=”50″ read_more=”true” new_window=”true” thumbnail=”150″]

    site is WP Multisite pulling from another subsite and uses WP Supercache, Autoptimize, and Cloudflare – don’t really know what the CPT is doing to mess things up. but older version of plugin works

    I’ll try again when next release comes out

    thanks

    • This topic was modified 1 year, 1 month ago by wasanajones.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Travis

    (@tjtaylor)

    Hello,

    The “check the shortcode” message usually means there is a type error within your shortcode. If you can post exactly what the error message says we can take a look. Version 1.5+ introduces more shortcode validation to prevent potential PHP warnings or errors.

    thanks for the prompt response. I’ll need to circle back around to disable/delete the old working version, and reinstall the new version and snap the error message then disable/delete the latest version and reinstall the old working version…

    I can say unequivocally it is NOT how the shortcode is written – it works on test post and with old version

    it has to do with validation / sanitation in the custom post type. whether that applies to all custom post types is something you might want to look at and test – whether it applies to this particular CPT is a painful problem

    thanks

    I inadvertently updated all my plugins…

    so I was like… ah, geez what now… oh… ha ha

    RSS ERROR – Invalid url value: . Please check your shortcode.

    for absolute sure, there is not a problem with the shortcode – only a problem in a custom post type and latest version of WPRSSFR

    thanks

    Hi – I might have solved this issue. Not completely tested, but might be fixed by adding to shortcode:

    ajax=”false”]

    thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Like a finely tuned race car’ is closed to new replies.