WordPress.org

Forums

Simple Lightbox
[resolved] Lightbox works with some images but not others (same gallery) (6 posts)

  1. anabasso
    Member
    Posted 1 year ago #

    Hello,
    I've been trying to solve this for days but can't find an explanation:
    The lightbox works great with most of the images, but it's not working with others.
    I've checked and can't see anything different (image size, file size). They are even in the same gallery and were all imported together.

    Would you guys please take a look? I could use some fresh pair of eyes :)
    http://www.teresarius.com/wp-temp/art/evacasanova

    Thanks a lot!
    Ana

    http://wordpress.org/plugins/simple-lightbox/

  2. Archetyped
    Member
    Plugin Author

    Posted 1 year ago #

    It appears to be due to the accented characters in the image file names.

    I will take a look at this, but for the short-term if you rename the files so that they don't contain accents, then SLB should work for all of the images.

  3. anabasso
    Member
    Posted 1 year ago #

    It appears to be it, of course!
    Thank you very much.

  4. Archetyped
    Member
    Plugin Author

    Posted 1 year ago #

    I've tested SLB with files containing accented characters and could not reproduce your issue. That is, SLB is working fine with files containing accented characters.

    Are you using any additional plugins or code that might affect how a file is uploaded or inserted into posts? It appears that the file names are being encoded in the post, causing a mismatch with their actual file names.

    Example:

    • File: 3D-Día.jpg
    • Name in page source (HTML): 3D-D%C3%ADa.jpg
  5. anabasso
    Member
    Posted 1 year ago #

    Thanks for looking into it.
    The theme I'm using had originally a different lightbox plugin, which I disabled to install SLB.

    This issue could be the result of an interference from another plugin, from the theme or from the code I’ve changed, but I’m afraid I wouldn’t know which one is it.

    In any case, the solution you proposed is brilliant and everything is working fine now :)

  6. Archetyped
    Member
    Plugin Author

    Posted 1 year ago #

    Good to hear, thanks for the update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Simple Lightbox
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.