Support » Plugin: Lightbox with PhotoSwipe » Lightbox with Photoswipe not working on flywheel hosted site

  • Resolved noorseerat

    (@noorseerat)


    Hi Arno,

    Thank you for the plugin. Please refer to the url below. It doesn’t seem to work on the site and the lightbox doesn’t open. Before the images on the page are loaded, I notice a small scrollbar type thing displayed as well. The site is hosted on Flywheel and I do know that the plugin works well without any issues on the exact copy of the site in my local dev environment. Could you please help out? Please use flywheel and debonair-back to get in the site. Do let me know if you need additional info.

    Best

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter noorseerat

    (@noorseerat)

    Adding to the previous: No cache is enabled on the site at present.Cache is cleared and is disabled currently.

    Plugin Author Arno Welzel

    (@awelzel)

    This is a known problem. However, I don’t have a fix for it.

    Flywheel uses a customized WordPress installation with separate locations for the WordPress core which is the same for any site and site specific folders for plugins, themes etc.. This causes Lightbox with PhotoSwipe to fail as it can’t determine the real path for images any longer.

    Also see here: https://github.com/arnowelzel/lightbox-photoswipe/issues/33

    Thread Starter noorseerat

    (@noorseerat)

    Thanks for the reply Arno..

    I’m not a developer so I’m unable to offer any more information on it. However while looking into gallery lightbox options and before I was happy with and finalized on “Lightbox with Photoswipe”, I’d come across this plugin which integrates PhotoSwipe into wordpress -> https://wordpress.org/plugins/boxers-and-swipers/

    I just installed this plugin on the staging site on flywheel, enabled photoswipe only on all devices and the lightbox pops up.. I’m not sure if there won’t be errors in all scenarios(like you mention in the github thread). Just thought I’d share with you. Does this offer any information that’ll help with the fix?

    Thanks

    Plugin Author Arno Welzel

    (@awelzel)

    Thanks for the hint.

    Boxers and Swipers uses a different WordPress filter to add the lightbox to the images. Instead of filtering the final HTML output of the page it works on the post content only. In this case there are other possibilities to get the image metadata which is required for PhotoSwipe.

    I’ll see what I can do.

    Thread Starter noorseerat

    (@noorseerat)

    I see; Thank you for looking into it Arno!

    Best

    Plugin Author Arno Welzel

    (@awelzel)

    I (hopefully) found a way to fix this. As I don’t have any Flywheel hosted site, it would help a lot, if you could test, if it works.

    You can send me an e-mail (you will find my contact address on my website https://arnowelzel.de/en/about-me) and I give a link where you can download a ZIP file with the modified version of the plugin.

    Edit: forget about the manual modification – this is not enough and pasting the whole code here makes no sense 😉

    • This reply was modified 1 year, 4 months ago by Arno Welzel.
    Plugin Author Arno Welzel

    (@awelzel)

    Version 3.1.6 should fix the issues with the hosting at Flywheel.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Lightbox with Photoswipe not working on flywheel hosted site’ is closed to new replies.