Support » Plugin: WordPress Gallery MaxGalleria » Lightbox under the headers in Grow Pro theme

  • I’m using the ThinkupThemes Grow Pro theme

    I think something similar has been covered previously but not on this theme.
    The top of the lightbox disappears under the header and menu bar.

    I think this is to do with the z-index

    I have tried some custom css but cannot figure out exactly what it should be? I think something like:

    .header-wrapper {
    z-index: 500;
    But this has no effect – have tried different values to the 500

    Any help would be greatly appreciated.
    Thank you.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author AlanP57


    I do not see a zindex problem on

    Hi Alan,

    Thank you for your reply.

    On this page: there is a separate gallery for each room (more than 2 pictures to be added to each eventually).

    The problem is with the galleries for rooms 1 and 2

    Please have a look at these screen shots:
    This is room 3 and all of the picture is visible in the light box including the “close pop up – X”
    This is a screen shot for room 1
    Here you can see that the top of the light box image is under the menu bar also the “close pop up – X” is missing.

    (If you scroll down the page until the menu bar is off the top of the screen before clicking on gallery 1 then it does show the full picture in the light box pop up).

    Maybe you are seeing something different on your computer?
    I have tried looking at it in Firefox, Chrome and IE – the problem is present in all 3.

    Thank you for your time.


    Plugin Author AlanP57


    I see it covers the light box. You could try changing the type of header in your theme options. The current header has a zindex of 99999 and if I disable that and increase the zindex of the light box, the header remains unchanged. You may need to address the issue to theme author.

    Thank you for your reply,

    I have opened a support ticket with ThinkUpThemes – I will let you know the outcome.


    Hi Alan,

    Here is the reply received from ThinkUpthemes:

    “Thank you for contacting us.

    The issue you’re experiencing it’s a plugin issue not a theme issue. You need to contact plugin author for the support in this issue. You can check the below link which was advised by the plugin author –

    This is not advised at all, the z-index of the theme should not be changed. The plugin author should debug their plugin and fix. It’s a plugin issue.

    You can suggest the plugin developer to address the z-index of the classes mfp-bg and mfp-wrap to be higher than the header. For example they can use the following custom css:

    .mfp-wrap {
    z-index: 999999;

    Apologies I couldn’t be of more assistance, we’re happy to help with any issues caused by the theme itself, but unfortunately are not best placed to assist with 3rd party issues.”

    Doesn’t look like this issue is solvable.


    Hi Alan,

    Any further thoughts on this problem?

    Would really like to stick with Maxgalleria if possible.


    Anyone else have any advice please?

    Can anyone help with this problem please?

    I have tried adding:

    .mfp-img {
    z-index: 99999999;

    to the theme custom code but nothing changes.

    I have experimented with other plugins but would really like to stick with Maxgallleria if possible.

    Plugin Author AlanP57


    I do not have any further idea for solving this issue. In the past I have been able to change the zindex of the theme header to fix these issues. Since nothing you or I have done has fixed it I believe that the problem is with the theme and not MaxGalleria.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Lightbox under the headers in Grow Pro theme’ is closed to new replies.