Support » Plugin: WooCommerce » lightbox setting disappeared

  • Resolved tabasco86



    I have another question. I’m using yith zoom magnifier and now it stopped working properly. As all my products are variable products the new woocommerce gallery doesn’t apply, right?

    Anyways, is there a way to activate the lightbox? Currently when users click the image they’re redirected to the image. I use divi

    Thanks and have a great day!


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Claudiu Lodromanean


    It sounds like your theme doesn’t have the new 3.0 gallery features enabled yet. You can add a few lines to the theme to activate them:,-swipe,-lightbox)-in-3.0.0

    Hi Claudiu,

    good call. Thanks!
    That did the trick. There was a theme update just a couple of days ago so I assumed they had included the new gallery settings.

    I have another question. Now the new gallery setting is working properly (great new feature), however it shows multiple products at once when I switch between images. The woocommerce-product-gallery__wrapper is displaying the wrong position for transform:
    width: 1600%;
    transition-duration: 0s;
    transform: translate3d(-571px, 0px, 0px);

    Where can I adjust this?

    Plugin Author Mike Jolley


    Check the CSS and ensure there are no conflicting styles in the theme. If it’s not the theme, log an issue on Github (this issue might get buried).

    Thanks for the fast reply. So far I haven’t found any conflicting css issues with the theme. If I do I’ll follow up here.
    Adding the following to my css solved the issue for desktop, however on mobile it’s calculating the size of the image wrongly, so this doesn’t resolve the issue. .woocommerce-product-gallery__image { position: relative; left: -40px;}

    Just created the issue on github.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘lightbox setting disappeared’ is closed to new replies.