Support » Plugin: WP Photo Album Plus » Lightbox problem in iPad Safari

  • Hi
    I’ve noticed that Lightbox works intermittently on Safari for iPad. Tapping on some photos in an album it works fine but on others it shows just the photo overlaid on the dimmed album page. Sometimes this will show the X at the top right to close the photo and sometimes it doesn’t. I’ve cleared the cache, checked all is updated but the problem still occurs.
    On an Android tablet there is a similar but different problem. Using Chrome some photos appear full screen with the description or photo name missing, other photos work fine.
    Any suggestions?

Viewing 8 replies - 16 through 23 (of 23 total)
  • Testing with Chrome & Safari. The majority now bypass Lightbox & open directly to the faulty full screen. The few that do open Lightbox initially then go to the faulty full screen when tapping on the full screen button.

    Oddly, although they mostly open in full screen, if you then tap on the now almost invisible full screen button they often revert to Lightbox.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I finally came to the conclusion that certain browsers under certain circumstances do not want to switch to fullscreen mode, for reasons of security – as they say – when it is too much programmed and not an immediate result of a user action. This also explains the worse behaviour with longer timings.

    What i will do is find out if i can detect this happening and then display the ‘normal’ lightbox.

    In the mean time i recommend to switch both starting modes to ‘normal’. This should work on all devices. If not, pls tell me.

    On my site, with both settings at ‘Normal’ thumbnails almost always open Lightbox. Tapping on the full screen button always displays the problem.
    On your test site all of the thumbnails now bypass Lightbox & display the problem.
    What would work for me would be if I could switch off the full screen button. I can’t find that option in Settings.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Add to the custom styles:

    #wppa-fulls-btn{display:none !important;}

    Oh well, not being paticularly technical I’m not sure how to do that so I”ll just leave it as it is. Thing is that sometimes when it goes to the problem full screen both the exit and full screen buttons do not appear so there’s no way to get back to the thumbnails. Only option is to use the browser’s back button which takes you elsewhere.
    Apple stikes again: ‘It just(doesn’t) work’.
    Thanks for your help Jacob.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    You can fill #wppa-fulls-btn{display:none !important;} into Table IV-A15. Copy-paste from the forum, not from the email.

    Thank you. That solves it.
    Great plugin, excellent support.

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.