WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Lightbox plugin not opening comic in lightbox

[Resolved] Lightbox plugin not opening comic in lightbox

  • I am having trouble getting any lightbox working with comic easel. I’m wondering if I don’t have a setting right in comic easel or if I’m missing something in the lightbox plugin. I’ve tried multiple different ones with the same result. All that happens is the image opens up in a new tab/window.

    The lightbox I currently have installed is WP Lightbox 2. I’ve tried WP Lightbox 2, wp-jquery-lightbox, Lightbox Plus ColorBox, and Simple Lightbox. In truth, the one I think I’d prefer to use is WP Lightbox 2 but I’ll take any recommendations if it will get a lightbox working.

    I am also using a custom child theme to comicpress.

    So, I have “Open comic up with Lightbox?” check marked, but no other options within “Misc. Comic Functionality”.

    In WP Lightbox 2, I have Auto-lightbox image links, and Shrink large images to fit smaller screens chekcmarked. I dont see any options that id think would cause the hook into comic easel/comicpress.

    Here is an example
    http://www.osfgalatea.com/comictest/comic/example-page-8-9/

    any help is appreciated.

    https://wordpress.org/plugins/comic-easel/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Frumph

    @frumph

    Have you tried Jetpack’s carousel module?

    That tends to override everything else

    I just tried by disabling the Carousel module and I am getting the same effect. I tried uploading a new page after disabling and it still opens the full image in a new window. I even deactivated the Jetpack plugin as a whole and no go. The comic page itself is getting the rel=”lightbox” tag on it so I’m not sure what isn’t working.

    —-

    After some further testing, I deactivated my comicpress child theme and activated Twenty Fourteen. After I put an image in the theme with the rel=”lightbox” the lightbox plugin started to work…

    So I installed the default comicpress theme and I again got the open in new window issue. Do you happen to know why comicpress would cause this issue and how to fix?

    Plugin Author Frumph

    @frumph

    yes, .. I know of the issue; there’s a script error on your site someplace (most likely within comicpress – probably the jquery for the menubar) and i’ve been working on tracking it down ..

    when a script errors out it pretty much makes other scripts fail

    Hi, I’m having the same problem but it happens with my costum theme and the Comic Press theme (latest version) too. Couldn’t make neither Carousel nor Easy Lightbox work with the comics (but they do work with the posts).
    I’m running wordpress locally, I don’t know if that changes anything.

    (*custom)

    Plugin Author Frumph

    @frumph

    go to the comicpress theme’s options -> menubar tab and disable the menu jquery, refresh your site clear browser/site cache and see if it then comes up, if it does .. then it’s the same problem others are having .. if it’s not, disable all plugins until you one that is conflicting.. or use some site js peaker and see if any errors come up

    Thanks for the answer! Sadly I had no luck. If I add the image to the post instead of as a Featured Image it works. Could it be a problem with Simple Lightbox? Is there a Lightbox plugin you would reccomend? (as for Jetpack’s Carousel, it only loads with Galleries).

    I’m trying to make the Lightbox work as a Comic displayer, using the navigation by cursor to read the comic (which means adding invisible links to the previous and later attachments via PHP so Simple Lightbox would pick them up). Suffice to say I’m not nearly close to succeding…

    Found this, which on a quick look solves the issue: http://archetyped.com/lab/slb-2-3-0/
    I’m gonna check it ou and get back to you if it doesn’t work. Thanks a lot for the support (seriously, not knowing ANY php it gets messy and the feedback helps a lot)

    Plugin Author Frumph

    @frumph

    How does that solve it though?

    I haven’t tried it yet but it says “Themes and plugins can now activate content that is not directly supported by SLB, such as featured images in templates or plugin-specific output” so I thought it could be used for the featured image.

    As for the “displaying the entire chapter on the Lightbox” issue, I’m having no luck. I’m trying to finish the rest of the theme and upload it so I can get better feedback.

    Plugin Author Frumph

    @frumph

    I’m still looking into this, since on my end it works with carousel in jetpack at the moment

    As I mentioned on the other post I’m no longer using Comic Press BUT I tried to do it and I can’t still, even using comic press theme, Jetpack/Carousel and a decent server

    Plugin Author Frumph

    @frumph

    .. my dev site: http://dev.frumph.net/blog/jetpack-carousel-test/

    works for me over here; wish I knew what you were doing when you were doing it so I could have done some checking myself; but didn’t think about it at the time

    I’ll tell you what, I’m finishing the site, when I’m done I’ll install another wordpress and test it again, if it doesn’t work you can help me then. Thank you very much, seriously.

    Plugin Author Frumph

    @frumph

    sounds like a plan!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Lightbox plugin not opening comic in lightbox’ is closed to new replies.