Support » Plugin: WooCommerce » Lightbox pics have inconsistent return method to product page

  • I’ve been looking at the pics in my developemnt site, and have noticed that the lightbox pics of products display in two different ways!

    Some products like this one – https://www.internetsquad.co.uk/product/21st-century-card-trick/ when clicking the magnifying glass of the small pic on product page will show the larger pic which then has a cursor arrow. Clicking the cursor again returns to the product page.

    Other products like this one – https://www.internetsquad.co.uk/product/21st-century-scissors/ when clicking the magnifying glass will bring up the larger pic, but this time the cursor changes to a magnifying glass. Clicking again enlarges the pic a tiny amount, and to return to the product page it is necessary to click a magnifying glass icon in top right hand corner.

    I can’t see what is making the lightbox pics behave in these different ways? All my pics are 800px wide, although the heights vary on some pics.

    Does anyone have any ideas why I’m getting these inconsistencies with my lightbox pics?

Viewing 4 replies - 1 through 4 (of 4 total)
  • I think it has something to do with your CSS or JavaScript

    Every time hover over the X is disappears, same for the magnifying glass.

    I’m not getting that in Firefox or Chrome. I’ll try and switch themes and see what happens! Thanks for the feedback. 🙂

    I’ve switched to WordPress 2016 theme, but I’m getting the same thing as before with the pics. Using WooCommerce 3.0.7

    The only other plugins activated are Yoast Seo, Table rate Shipping, and Akismet. I can’t see that any of these should cause an issue.

    The lightbox pics always respond the same for the pics that are selected. In other words, a pic that shows an arrow cursor will always show an arrow cursor, and a pic where the cursor changes to a magnifying glass will always show a magnifying glass.

    I think I’ve found a pattern which suggests what is going on.

    The lightbox pics all seem to have different sizes as far as height and width. The pics that are quite wide don’t have the magnifying glass, whereas the others do!

    So I suspect the results I’m getting are what they are supposed to be based on the height and width of the pics.

    What I don’t understand though is that all the pics I’ve uploaded have a width of 800px, yet I seem to have ended up with all these different width pics when it comes to viewing the lightbox version! What’s that all about?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Lightbox pics have inconsistent return method to product page’ is closed to new replies.