Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Lifespan expiration date not working

  • Resolved therealshadowhunter

    (@therealshadowhunter)


    Hi Forminator-team,

    I hope you are doing well?

    I created a really simple form, tested it and it works fine. Next I have set the lifespan expiration date to 16 March 2021.

    As soon as I set the lifespan expiration date the form is no longer shown on the front end. No matter what date I try, the form remains hidden.

    I cannot imagine such a trivial feature was not tested so I expect this to be a date format issue? I’m using WP 5.6.1 and Forminator 1.14.8. My date notation is set to “j F Y” and server date/time seems to be correct.

    Looking forward to your feedback.

    Thank you for this amazing plugin and your kinds support.

    With best regards,

    TheRealShadowHunter

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Patrick Cohen – WPMU DEV Support

    (@wpmudevsupport16)

    Hi there @therealshadowhunter

    I managed to replicate this issue on my test site only if I manually enter/edit the date in Lifespan field.

    If I select the same date from the calendar dropdown in that field, it works as expected.

    Can you please check if that’s perhaps the case on your end as well?

    In the meantime, I’ll report this UI issue to the developers, and I’m surprised it hasn’t come up before. 🙂

    Cheers!
    Patrick

    Thread Starter therealshadowhunter

    (@therealshadowhunter)

    Hello Patrick,

    Thank you for your feedback and for confirming there is indeed some issue.

    At my side the form remains hidden whether I select the date form the datepicker or input it manually (I tried several formats)

    I have my WP language to “Dutch”, Timezone: “Brussels”, Date format: “j F Y” and Time format “H:i”

    Again, thank you for your kind support.

    Looking forward to the outcome.

    With best regards,

    The RealShadowHunter

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @therealshadowhunter ,

    Can you export your form and share it with us. You can use pastebin.com or gdrive/dropbox to share.

    kind regards,
    Kasia

    Thread Starter therealshadowhunter

    (@therealshadowhunter)

    Hello Kasia,

    Thank you for your feedback.

    Please find the export at pastebin.com: https://pastebin.com/r0E5fHdK

    Looking forward to your feedback.

    With best regards,

    TheRealShadowHunter

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @therealshadowhunter

    Thank you for sharing the form!

    I imported it to my site and I was able to instantly replicate the issue even though I had English language set on site, with default date/time formats.

    But when I set the lifespan expiration date again, it started to work fine.

    So I did some more testing and it seems it has something to do with language itself, most likely translations, not so much with the date format. I tested some languages and I could set it all fine (regardless of the date format I chose) if Forminator itself wasn’t translated.

    I think this is yet another issue that somehow passed through QA tests and I’ve already reported it to our developers as well.

    As a workaround, what seems to be working would be: switch the site language temporarily to English, go to edit the form and set that expiration date again and save, then switch language of the site back to as you want it to be.

    Best regards,
    Adam

    Thread Starter therealshadowhunter

    (@therealshadowhunter)

    Hello Adam,

    Thank you for your prompt feedback and investigations.

    I’m happy to hear you could duplicate the issue and are on the right track to find a countermeasure.

    Thank you for your temporary workaround but alas I use several plugins that depend for frontend on the WP-language. So it is alas not possible to switch languages. I guess for now I will just manually disable to form at the due date.

    I hope to see the fix appearing a future release though.

    For now, thank you and have a great day.

    With best regards,

    ShadowHunter

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @therealshadowhunter

    I hope you are doing well.

    We already reported this issue to the plugin team, I am afraid we can’t give an estimated time for the fixed version, but I hope it is on a close release.

    We are marking this as resolved for now, please, keep the eyes on the plugin updates and changelogs.

    Feel free to re-open or reply to the ticket if you need any further help.
    Best Regards
    Patrick Freitas

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Lifespan expiration date not working’ is closed to new replies.